php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58816 pecl package installation error
Submitted: 2009-08-18 05:58 UTC Modified: 2013-01-06 16:52 UTC
Votes:2
Avg. Score:2.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: sdfl201 at yahoo dot com Assigned:
Status: Not a bug Package: PECL (PECL)
PHP Version: 5.2.6 OS: ubuntu jaunty
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sdfl201 at yahoo dot com
New email:
PHP Version: OS:

 

 [2009-08-18 05:58 UTC] sdfl201 at yahoo dot com
Description:
------------
Description:
------------
when i try to install any package with pecl , system gives this error

$ pecl install svn-beta
Cannot install, php_dir for channel "pecl.php.net" is not writeable by
the current user
fatih@fatih-laptop:~$ sudo pecl install svn-beta
[sudo] password for fatih: 
downloading svn-0.5.0.tgz ...
Starting to download svn-0.5.0.tgz (23,504 bytes)
........done: 23,504 bytes
ERROR: Unknown Role class:
"PEAR_Installer_Role_Pear_Installer_role_doc"



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-04-03 18:46 UTC] cmonahan at yahoo dot com
I had this error because /usr was mounted readonly. Run "mount -o remount,rw /usr" then try your command again.
 [2012-06-25 17:17 UTC] mak at mak-sfc dot com
You don't need to modify the chmod for all the /usr directory. You just have to 
run PECL as super user. Juste type sudo pecl <whatever>...
-mak
 [2012-09-21 09:53 UTC] raphael dot droz at gmail dot com
If you set a local pear directory:
$ pear config-set ext_dir ~/.pear/extensions
this will work for pear, but NOT for pecl:
$ pear install pecl/Mailparse
[...]
running: make INSTALL_ROOT="/home/user/.pear/extensions/tmp/..."
[...]
Installing '/usr/lib/php5/20100525+lfs/mailparse.so'
ERROR: failed to write /usr/lib/php5/20100525+lfs/mailparse.so ...

(Debian, php-pear, 5.4.4-7)
 [2012-09-21 10:07 UTC] raphael dot droz at gmail dot com
looks like if https://pear.php.net/bugs/bug.php?id=6480 wasn't really fixed.
 [2012-09-21 10:55 UTC] raphael dot droz at gmail dot com
(correction: using PEAR Version: 1.9.4)
 [2013-01-06 16:41 UTC] tyrael@php.net
-Status: Open +Status: Not a bug
 [2013-01-06 16:41 UTC] tyrael@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 [2013-01-06 16:52 UTC] tyrael@php.net
-Package: PECL bug system +Package: PECL
 [2013-01-06 16:52 UTC] tyrael@php.net
please disregard my previous reply, I selected a wrong reason for the status 
change.
the issue that you brought up and discussed here is a (possible) problem in the 
PEAR package.
you can open a bugreport on http://pear.php.net/bugs for this package
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 29 23:01:23 2020 UTC