php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58764 Problems with install oauth using PECL
Submitted: 2009-07-15 17:41 UTC Modified: 2009-10-04 03:09 UTC
From: mitul dot ruparelia at gmail dot com Assigned:
Status: Closed Package: oauth (PECL)
PHP Version: 5.1.2 OS: Ubuntu
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
33 + 15 = ?
Subscribe to this entry?

 
 [2009-07-15 17:41 UTC] mitul dot ruparelia at gmail dot com
Description:
------------
Hi, 

I am trying to install the PECL oauth package (version 0.99.9) from: http://pecl.php.net/package/oauth

However, the installation fails:

root@lvps212-241-214-42:/usr/include/php5/ext# pecl install oauth-beta
downloading oauth-0.99.9.tgz ...
Starting to download oauth-0.99.9.tgz (25,609 bytes)
.........done: 25,609 bytes
4 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20050922
Zend Extension Api No:   220051025
building in /var/tmp/pear-build-root/oauth-0.99.9
running: /tmp/tmp6mnqls/oauth-0.99.9/configure
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking whether gcc and cc understand -c and -o together... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext
checking for PHP extension directory... /usr/lib/php5/20051025
checking for PHP installed headers prefix... /usr/include/php5
checking for re2c... no
configure: WARNING: You will need re2c 0.9.11 or later if you want to regenerate PHP parsers.
checking for gawk... gawk
checking for oauth support... yes, shared
configure: error:
You've configured extension oauth, which depends on extension curl,
but you've either not enabled curl, or have disabled it.

ERROR: `/tmp/tmp6mnqls/oauth-0.99.9/configure' failed


I have installed curl and it is enabled. See below:

root@lvps212-241-214-42:/usr/include/php5/ext# curl
curl: try 'curl --help' or 'curl --manual' for more information


The curl module is also enabled on my PHP file, and all the PHP curl commands work fine:

root@lvps212-241-214-42:/usr/include/php5# more /etc/php5/apache2/php.ini
extension=curl.so


Do you have any suggestions on how I can install and use oauth?

Kind regards, 

Mitul

Reproduce code:
---------------
To reproduce:

pecl install oauth-beta

Expected result:
----------------
File has been installed successfully.

Actual result:
--------------
downloading oauth-0.99.9.tgz ...
Starting to download oauth-0.99.9.tgz (25,609 bytes)
.........done: 25,609 bytes
4 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20050922
Zend Extension Api No:   220051025
building in /var/tmp/pear-build-root/oauth-0.99.9
running: /tmp/tmp6mnqls/oauth-0.99.9/configure
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking whether gcc and cc understand -c and -o together... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext
checking for PHP extension directory... /usr/lib/php5/20051025
checking for PHP installed headers prefix... /usr/include/php5
checking for re2c... no
configure: WARNING: You will need re2c 0.9.11 or later if you want to regenerate PHP parsers.
checking for gawk... gawk
checking for oauth support... yes, shared
configure: error:
You've configured extension oauth, which depends on extension curl,
but you've either not enabled curl, or have disabled it.

ERROR: `/tmp/tmp6mnqls/oauth-0.99.9/configure' failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-07-16 03:11 UTC] mitul dot ruparelia at gmail dot com
- Changed Package to oauth
 [2009-07-18 01:36 UTC] mitul dot ruparelia at gmail dot com
I've updated some of the PHP modules etc. However, problem 
still exists:

root@lvps212-241-214-42:~# pecl install oauth-beta
downloading oauth-0.99.9.tgz ...
Starting to download oauth-0.99.9.tgz (25,609 bytes)
.........done: 25,609 bytes
4 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20050922
Zend Extension Api No:   220051025
building in /var/tmp/pear-build-root/oauth-0.99.9
running: /tmp/pear/temp/oauth/configure
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking whether gcc and cc understand -c and -o together... 
yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php5 -
I/usr/include/php5/main -I/usr/include/php5/TSRM -
I/usr/include/php5/Zend -I/usr/include/php5/ext
checking for PHP extension directory... 
/usr/lib/php5/20051025
checking for PHP installed headers prefix... 
/usr/include/php5
checking for re2c... re2c
checking for re2c version... 0.9.12 (ok)
checking for gawk... gawk
checking for oauth support... yes, shared
configure: error:
You've configured extension oauth, which depends on 
extension curl,
but you've either not enabled curl, or have disabled it.

ERROR: `/tmp/pear/temp/oauth/configure' failed
 [2009-09-11 14:51 UTC] junichi at concertcoop dot com
I was having this problem as well on Ubunutu with curl 
installed. I was able to get OAuth pecl install to work by 
installing the ubuntu package, libcurl3-dev.
 [2009-10-04 03:09 UTC] jawed@php.net
Sorry, but your problem does not imply a bug in PECL itself.  For a
list of more appropriate places to ask for help using PECL, please
visit http://pecl.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PECL.

Yes, you would need curl headers.
 [2009-12-31 12:32 UTC] developer at webfabriek-rotterdam dot nl
HOI. there,

It helped me to install curl from source.

http://curl.haxx.se/docs/install.html


First I removed curl from with

(sudo) aptitude remove curl

Then I followed the installation steps of 

http://curl.haxx.se/docs/install.html

There were some minor issues with after make test

Fore example

TESTDONE: 543 tests were considered during 242 seconds.
TESTINFO: 112 tests were skipped due to these restraints:
TESTINFO: "curl lacks SSL support" 23 times (94, 300, 301, 
302, 303, 304, 305, 306, 309, 310, 311, 312, 400, 401, 402, 
403, 404, 405, 406, 407, 408, 409, 560)
TESTINFO: "rlimit problem: fds needed 1050 > system limit 
1024" 1 times (518)
TESTINFO: "curl lacks scp support" 10 times (601, 603, 605, 
607, 617, 619, 621, 623, 629, 631)
TESTINFO: "curl lacks netrc_debug support" 6 times (130, 
131, 132, 133, 134, 257)
TESTINFO: "curl lacks OpenSSL support" 2 times (307, 308)
TESTINFO: "failed starting SSH server" 6 times (700, 701, 
702, 703, 706, 707)
TESTINFO: "configured as DISABLED" 2 times (563, 564)
TESTINFO: "Resolving IPv6 'ip6-localhost' didn't work" 2 
times (241, 1083)
TESTINFO: "curl lacks idn support" 3 times (165, 1034, 1035)
TESTINFO: "curl lacks NTLM support" 28 times (67, 68, 69, 
70, 81, 89, 90, 91, 150, 155, 159, 162, 169, 170, 176, 209, 
213, 239, 243, 265, 267, 547, 548, 555, 1008, 1021, 1097, 
1100)
TESTINFO: "curl lacks sftp support" 29 times (600, 602, 604, 
606, 608, 609, 610, 611, 612, 613, 614, 615, 616, 618, 620, 
622, 624, 625, 626, 627, 628, 630, 632, 633, 634, 635, 636, 
637, 2004)

Just ignore them and go though with make install

After that repeat 

pecl install oauth-beta

That worked for me.

Hopefully someone else will profit from my findings.

Have a good time.

Bye, Christine
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Oct 21 15:03:34 2021 UTC