php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58725 Configuration directives
Submitted: 2009-06-16 16:45 UTC Modified: 2009-06-16 19:33 UTC
From: hdev at gmail dot com Assigned:
Status: Not a bug Package: inclued (PECL)
PHP Version: 5.2.6 OS: Linux/Debian 5.0.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hdev at gmail dot com
New email:
PHP Version: OS:

 

 [2009-06-16 16:45 UTC] hdev at gmail dot com
Description:
------------
inclued directives (inclued.enabled, inclued.dumpdir) cant be set in user scripts, htaccess or apache conf files

Reproduce code:
---------------
/etc/php5/apache2/php.ini

extension=inclued.so
inclued.enabled=1
inclued.dumpdir=/tmp

=> WORK


/etc/apache2/sites-available/incluedtest.dev.ap2
php_flag inclued.enabled on
php_value inclued.dumpdir /tmp

=> DONT WORK


.htaccess
php_flag inclued.enabled on
php_value inclued.dumpdir /tmp

=> DONT WORK


php script
ini_set('inclued.enabled', 1);
ini_set('inclued.dumpdir', '/tmp');

=> DONT WORK

Expected result:
----------------
I would have : 
inclued.dumpdir    /tmp        no value
inclued.enabled	   On	       Off

Actual result:
--------------
My phpinfo return : 
inclued.dumpdir    no value    no value
inclued.enabled	   Off	       Off

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-06-16 19:33 UTC] hdev at gmail dot com
Not a bug, the two directives are PHP_INI_SYSTEM.

The documentation (http://www.php.net/manual/fr/inclued.configuration.php) would be improved :

PHP_INI_* -> PHP_INI_SYSTEM
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Jan 27 08:01:26 2021 UTC