php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58681 does not build with php-5.3.x
Submitted: 2009-05-18 12:37 UTC Modified: 2009-11-24 07:44 UTC
From: oeriksson at mandriva dot com Assigned:
Status: Closed Package: bcompiler (PECL)
PHP Version: 5.3.0RC2 OS: Mandriva Cooker
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: oeriksson at mandriva dot com
New email:
PHP Version: OS:

 

 [2009-05-18 12:37 UTC] oeriksson at mandriva dot com
Description:
------------
bcompiler does not build with php-5.3.0RC2

Reproduce code:
---------------
as done usually

Expected result:
----------------
should build

Actual result:
--------------
[...]
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:1342:8: warning: extra tokens at end of #endif directive                      
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c: In function 'apc_serialize_arg_info':                                        
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:1961: warning: passing argument 1 of 'apc_serialize_zstring' discards qualifiers from pointer target type
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:1965: warning: passing argument 1 of 'apc_serialize_zstring' discards qualifiers from pointer target type
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c: In function 'apc_create_arg_info':
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:1985: warning: passing argument 1 of 'apc_create_string2' from incompatible pointer type
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:1988: warning: passing argument 1 of 'apc_create_string2' from incompatible pointer type
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c: In function 'apc_serialize_zval':
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:2595: error: 'zval' has no member named 'is_ref'
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:2596: error: 'zval' has no member named 'refcount'
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c: In function 'apc_deserialize_zval':
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:2604: error: 'zval' has no member named 'is_ref'
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:2605: error: 'zval' has no member named 'refcount'
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c: In function 'apc_serialize_zend_function_entry':
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:2631: warning: passing argument 1 of 'apc_serialize_string' discards qualifiers from pointer target type
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:2639: warning: passing argument 1 of 'apc_serialize_arg_info' discards qualifiers from pointer target type
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c: In function 'apc_deserialize_zend_function_entry':
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:2651: warning: passing argument 1 of 'apc_create_string2' from incompatible pointer type
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:2660: warning: passing argument 1 of 'apc_create_arg_info' discards qualifiers from pointer target type
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c: In function 'apc_serialize_zend_class_entry':
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:2841: warning: assignment discards qualifiers from pointer target type
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:2848: warning: passing argument 1 of 'apc_serialize_zend_function_entry' discards qualifiers from pointer target type
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c: In function 'apc_deserialize_zend_class_entry':
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:3055: error: assignment of read-only location '*(zce->builtin_functions + (unsigned int)((unsigned int)count * 20u))'
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:3057: warning: passing argument 1 of 'apc_deserialize_zend_function_entry' discards qualifiers from pointer target type
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c: In function 'apc_serialize_zend_op_array':
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:3347: error: 'zend_op_array' has no member named 'uses_this'
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c: In function 'apc_deserialize_zend_op_array':
/home/oden/RPM/BUILD/bcompiler-0.8/bcompiler.c:3623: error: 'zend_op_array' has no member named 'uses_this'
[...]

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-07-05 16:57 UTC] kaspernj at gmail dot com
I cant build it on Ubuntu Jaunty i386 either.

Tried to build via the "pecl"-script like this:
sudo pecl install -f bcompiler


WARNING: failed to download pecl.php.net/bcompiler within preferred state "stable", will instead download version 0.8, stability "beta"
downloading bcompiler-0.8.tar ...
Starting to download bcompiler-0.8.tar (Unknown size)
.................................done: 215,040 bytes
10 source files, building
WARNING: php_bin /opt/php53/bin/php appears to have a suffix 53/bin/php, but config variable php_suffix does not match
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
configure.in:150: warning: AC_CACHE_VAL(lt_prog_compiler_static_works, ...): suspicious cache-id, must contain _cv_ to be cached
../../lib/autoconf/general.m4:1974: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:1994: AC_CACHE_CHECK is expanded from...
aclocal.m4:3555: AC_LIBTOOL_LINKER_OPTION is expanded from...
aclocal.m4:5493: _LT_AC_LANG_C_CONFIG is expanded from...
aclocal.m4:5492: AC_LIBTOOL_LANG_C_CONFIG is expanded from...
aclocal.m4:2972: AC_LIBTOOL_SETUP is expanded from...
aclocal.m4:2952: _AC_PROG_LIBTOOL is expanded from...
aclocal.m4:2915: AC_PROG_LIBTOOL is expanded from...
configure.in:150: the top level
configure.in:150: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works, ...): suspicious cache-id, must contain _cv_ to be cached
aclocal.m4:3510: AC_LIBTOOL_COMPILER_OPTION is expanded from...
aclocal.m4:7620: AC_LIBTOOL_PROG_COMPILER_PIC is expanded from...
configure.in:150: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_CXX, ...): suspicious cache-id, must contain _cv_ to be cached
aclocal.m4:5606: _LT_AC_LANG_CXX_CONFIG is expanded from...
aclocal.m4:5605: AC_LIBTOOL_LANG_CXX_CONFIG is expanded from...
aclocal.m4:4641: _LT_AC_TAGCONFIG is expanded from...
configure.in:150: warning: AC_CACHE_VAL(lt_prog_compiler_static_works, ...): suspicious cache-id, must contain _cv_ to be cached
../../lib/autoconf/general.m4:1974: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:1994: AC_CACHE_CHECK is expanded from...
aclocal.m4:3555: AC_LIBTOOL_LINKER_OPTION is expanded from...
aclocal.m4:5493: _LT_AC_LANG_C_CONFIG is expanded from...
aclocal.m4:5492: AC_LIBTOOL_LANG_C_CONFIG is expanded from...
aclocal.m4:2972: AC_LIBTOOL_SETUP is expanded from...
aclocal.m4:2952: _AC_PROG_LIBTOOL is expanded from...
aclocal.m4:2915: AC_PROG_LIBTOOL is expanded from...
configure.in:150: the top level
configure.in:150: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works, ...): suspicious cache-id, must contain _cv_ to be cached
aclocal.m4:3510: AC_LIBTOOL_COMPILER_OPTION is expanded from...
aclocal.m4:7620: AC_LIBTOOL_PROG_COMPILER_PIC is expanded from...
configure.in:150: warning: AC_CACHE_VAL(lt_prog_compiler_pic_works_CXX, ...): suspicious cache-id, must contain _cv_ to be cached
aclocal.m4:5606: _LT_AC_LANG_CXX_CONFIG is expanded from...
aclocal.m4:5605: AC_LIBTOOL_LANG_CXX_CONFIG is expanded from...
aclocal.m4:4641: _LT_AC_TAGCONFIG is expanded from...
building in /var/tmp/pear-build-root/bcompiler-0.8
running: /tmp/pear/download/bcompiler-0.8/configure
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for PHP prefix... /opt/php53
checking for PHP includes... -I/opt/php53/include/php -I/opt/php53/include/php/main -I/opt/php53/include/php/TSRM -I/opt/php53/include/php/Zend -I/opt/php53/include/php/ext -I/opt/php53/include/php/ext/date/lib
checking for PHP extension directory... /opt/php53/lib/php/extensions/no-debug-non-zts-20090626
checking for PHP installed headers prefix... /opt/php53/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... re2c
checking for re2c version... 0.13.5 (ok)
checking for gawk... gawk
checking whether to enable bcompiler support... yes, shared
checking for BZip2 in default path... found in /usr
checking for BZ2_bzerror in -lbz2... yes
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking the maximum length of command line arguments... 32768
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if cc static flag  works... yes
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC
checking if cc PIC flag -fPIC works... yes
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/bash /var/tmp/pear-build-root/bcompiler-0.8/libtool --mode=compile cc  -I. -I/tmp/pear/download/bcompiler-0.8 -DPHP_ATOM_INC -I/var/tmp/pear-build-root/bcompiler-0.8/include -I/var/tmp/pear-build-root/bcompiler-0.8/main -I/tmp/pear/download/bcompiler-0.8 -I/opt/php53/include/php -I/opt/php53/include/php/main -I/opt/php53/include/php/TSRM -I/opt/php53/include/php/Zend -I/opt/php53/include/php/ext -I/opt/php53/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/download/bcompiler-0.8/bcompiler.c -o bcompiler.lo
mkdir .libs
 cc -I. -I/tmp/pear/download/bcompiler-0.8 -DPHP_ATOM_INC -I/var/tmp/pear-build-root/bcompiler-0.8/include -I/var/tmp/pear-build-root/bcompiler-0.8/main -I/tmp/pear/download/bcompiler-0.8 -I/opt/php53/include/php -I/opt/php53/include/php/main -I/opt/php53/include/php/TSRM -I/opt/php53/include/php/Zend -I/opt/php53/include/php/ext -I/opt/php53/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/download/bcompiler-0.8/bcompiler.c  -fPIC -DPIC -o .libs/bcompiler.o
/tmp/pear/download/bcompiler-0.8/bcompiler.c:1342:8: warning: extra tokens at end of #endif directive
/tmp/pear/download/bcompiler-0.8/bcompiler.c: In function 'apc_serialize_arg_info':
/tmp/pear/download/bcompiler-0.8/bcompiler.c:1961: warning: passing argument 1 of 'apc_serialize_zstring' discards qualifiers from pointer target type
/tmp/pear/download/bcompiler-0.8/bcompiler.c:1965: warning: passing argument 1 of 'apc_serialize_zstring' discards qualifiers from pointer target type
/tmp/pear/download/bcompiler-0.8/bcompiler.c: In function 'apc_create_arg_info':
/tmp/pear/download/bcompiler-0.8/bcompiler.c:1985: warning: passing argument 1 of 'apc_create_string2' from incompatible pointer type
/tmp/pear/download/bcompiler-0.8/bcompiler.c:1988: warning: passing argument 1 of 'apc_create_string2' from incompatible pointer type
/tmp/pear/download/bcompiler-0.8/bcompiler.c: In function 'apc_serialize_zval':
/tmp/pear/download/bcompiler-0.8/bcompiler.c:2595: error: 'zval' has no member named 'is_ref'
/tmp/pear/download/bcompiler-0.8/bcompiler.c:2596: error: 'zval' has no member named 'refcount'
/tmp/pear/download/bcompiler-0.8/bcompiler.c: In function 'apc_deserialize_zval':
/tmp/pear/download/bcompiler-0.8/bcompiler.c:2604: error: 'zval' has no member named 'is_ref'
/tmp/pear/download/bcompiler-0.8/bcompiler.c:2605: error: 'zval' has no member named 'refcount'
/tmp/pear/download/bcompiler-0.8/bcompiler.c: In function 'apc_serialize_zend_function_entry':
/tmp/pear/download/bcompiler-0.8/bcompiler.c:2631: warning: passing argument 1 of 'apc_serialize_string' discards qualifiers from pointer target type
/tmp/pear/download/bcompiler-0.8/bcompiler.c:2639: warning: passing argument 1 of 'apc_serialize_arg_info' discards qualifiers from pointer target type
/tmp/pear/download/bcompiler-0.8/bcompiler.c: In function 'apc_deserialize_zend_function_entry':
/tmp/pear/download/bcompiler-0.8/bcompiler.c:2651: warning: passing argument 1 of 'apc_create_string2' from incompatible pointer type
/tmp/pear/download/bcompiler-0.8/bcompiler.c:2660: warning: passing argument 1 of 'apc_create_arg_info' discards qualifiers from pointer target type
/tmp/pear/download/bcompiler-0.8/bcompiler.c: In function 'apc_serialize_zend_class_entry':
/tmp/pear/download/bcompiler-0.8/bcompiler.c:2841: warning: assignment discards qualifiers from pointer target type
/tmp/pear/download/bcompiler-0.8/bcompiler.c:2848: warning: passing argument 1 of 'apc_serialize_zend_function_entry' discards qualifiers from pointer target type
/tmp/pear/download/bcompiler-0.8/bcompiler.c: In function 'apc_deserialize_zend_class_entry':
/tmp/pear/download/bcompiler-0.8/bcompiler.c:3055: error: assignment of read-only location '*(zce->builtin_functions + (unsigned int)((unsigned int)count * 20u))'
/tmp/pear/download/bcompiler-0.8/bcompiler.c:3057: warning: passing argument 1 of 'apc_deserialize_zend_function_entry' discards qualifiers from pointer target type
/tmp/pear/download/bcompiler-0.8/bcompiler.c: In function 'apc_serialize_zend_op_array':
/tmp/pear/download/bcompiler-0.8/bcompiler.c:3347: error: 'zend_op_array' has no member named 'uses_this'
/tmp/pear/download/bcompiler-0.8/bcompiler.c: In function 'apc_deserialize_zend_op_array':
/tmp/pear/download/bcompiler-0.8/bcompiler.c:3623: error: 'zend_op_array' has no member named 'uses_this'
make: *** [bcompiler.lo] Error 1
ERROR: `make' failed
 [2009-07-05 19:45 UTC] alan at akbkhome dot com
Can you try CVS
I doubt 0.8 will work with 5.3 due to all the changes.

cvs -d :pserver:cvsread@cvs.php.net:/repository checkout pecl/bcompiler
 [2009-09-19 23:22 UTC] logan at loganmcgrath dot com
I just tried installing it for 5.3 on OpenSUSE, and I got the very same errors.

Time to write some updates lol.
 [2009-10-05 12:03 UTC] wouterbulten at mai-ai dot org
Same error here on Mac OSX with php5.3-RC4
 [2009-10-05 19:34 UTC] alan at akbkhome dot com
Note to Commenters:
Please do not report that the package does not build on your OS - as this does not help in any way.

Confirming that the version in SVB does/doesn't build would be useful.
 [2009-11-23 13:34 UTC] val@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 [2009-11-23 13:44 UTC] oeriksson at mandriva dot com
I hope you meant it was fixed in SVN?
 [2009-11-24 07:44 UTC] oeriksson at mandriva dot com
The latest code from svn built fine. Thought there are quite a lot of build warnings that probably should be fixed as well. I built against latest php-5.3.1 and on Mandriva Linux 2010.0 x86_64
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 15:03:14 2021 UTC