php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58665 http_redirect fails
Submitted: 2009-05-10 12:00 UTC Modified: 2009-10-08 04:40 UTC
From: crrodriguez at opensuse dot org Assigned: mike (profile)
Status: Closed Package: pecl_http (PECL)
PHP Version: 5.2.9 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: crrodriguez at opensuse dot org
New email:
PHP Version: OS:

 

 [2009-05-10 12:00 UTC] crrodriguez at opensuse dot org
Description:
------------
if you use example 1 of the documentation http_redirect does not return the expected result



Reproduce code:
---------------
http://php.net/http_redirect

Expected result:
----------------
correct http redirect

Actual result:
--------------
http://www.cristianrodriguez.net/index2.php 

see the resulting URL

Redirecting to spr-itunes://www.cristianrodriguez.net/relpath?name=value.

using abolute url as first param works correctly.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-11 01:47 UTC] mike@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PECL.



 [2009-05-11 16:31 UTC] crrodriguez at opensuse dot org
This is a weird problem, upgraded the machine to a new OS version and the issue is gone, it may be a compiler or toolchain issue, I was unable to debug the problem.
 [2009-10-08 03:14 UTC] imai at glatts dot com
I've encountered the same problem.

package: pecl_http 1.6.5
os: Fedora 11
php: php.i586 5.2.9-2.fc11

Reproduce code:
---------------
<?php http_redirect("foo.html"); ?>

Expected result:
----------------
Redirecting to <a href="http://localhost.localdomain/foo.html">http://localhost.localdomain/foo.html</a>.

Actual result:
--------------
Redirecting to <a href="spr-itunes://localhost.localdomain/foo.html">spr-itunes://localhost.localdomain/foo.html</a>.

If following line is defined in /etc/services, http_redirect("foo.html") result was actual one.

spr-itunes      0/tcp   spl-itunes      # Shirt Pocket netTunes

If commented out this line, the result was expected one.
This line is defined in default /etc/services file of Fedora 11.
 [2009-10-08 04:40 UTC] mike@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 26 03:03:35 2021 UTC