php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #58654 Wrong dependent PHP version
Submitted: 2009-04-28 07:03 UTC Modified: 2009-05-11 03:07 UTC
From: nick dot telford at fav dot or dot it Assigned:
Status: Closed Package: oauth (PECL)
PHP Version: 5.1.6 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
24 + 32 = ?
Subscribe to this entry?

 
 [2009-04-28 07:03 UTC] nick dot telford at fav dot or dot it
Description:
------------
The documentation states that PHP 5.1.0 is required for this PECL extension, however, I am unable to get it to compile on PHP 5.1.6.

After investigation, it appears to require a macro PHP_GINIT_FUNCTION (and possibly others) that is defined in main/php.h.

However, this macro is not present in PHP 5.1.6. I don't know exactly when it appeared, but I'm sure it wasn't before 5.1.6. Possibly 5.2.0?

Please update the documentation to reflect the new minimum required version. I just wasted an entire morning tracking down this problem.

Reproduce code:
---------------
Attempt to install/compile pecl/oauth with PHP 5.1.6 or older.

Expected result:
----------------
The extension should successfully compile and install.

Actual result:
--------------
running: make
/bin/sh /var/tmp/pear-build-root/oauth-0.99.7/libtool --mode=compile gcc  -I. -I/tmp/tmphQFj8c/oauth-0.99.7 -DPHP_ATOM_INC -I/var/tmp/pear-build-root/oauth-0.99.7/include -I/var/tmp/pear-build-root/oauth-0.99.7/main -I/tmp/tmphQFj8c/oauth-0.99.7 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext  -DHAVE_CONFIG_H  -g -O2 -Wall -g   -c /tmp/tmphQFj8c/oauth-0.99.7/oauth.c -o oauth.lo
mkdir .libs
 gcc -I. -I/tmp/tmphQFj8c/oauth-0.99.7 -DPHP_ATOM_INC -I/var/tmp/pear-build-root/oauth-0.99.7/include -I/var/tmp/pear-build-root/oauth-0.99.7/main -I/tmp/tmphQFj8c/oauth-0.99.7 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -DHAVE_CONFIG_H -g -O2 -Wall -g -c /tmp/tmphQFj8c/oauth-0.99.7/oauth.c  -fPIC -DPIC -o .libs/oauth.o
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:76: warning: type defaults to 'int' in declaration of 'PHP_GINIT_FUNCTION'
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:76: warning: parameter names (without types) in function declaration
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:85: warning: return type defaults to 'int'
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c: In function 'PHP_GINIT_FUNCTION':
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:86: error: invalid type argument of '->'
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c: At top level:
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1709: warning: implicit declaration of function 'PHP_MODULE_GLOBALS'
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1709: error: 'oauth' undeclared here (not in a function)
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1709: error: initializer element is not constant
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1709: error: (near initialization for 'oauth_module_entry.post_deactivate_func')
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1710: warning: implicit declaration of function 'PHP_GINIT'
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1710: error: initializer element is not constant
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1710: error: (near initialization for 'oauth_module_entry.globals_id')
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1711: warning: initialization makes integer from pointer without a cast
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1712: warning: initialization makes integer from pointer without a cast
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1713: warning: excess elements in struct initializer
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1713: warning: (near initialization for 'oauth_module_entry')
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1713: warning: excess elements in struct initializer
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1713: warning: (near initialization for 'oauth_module_entry')
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1714: warning: excess elements in struct initializer
/tmp/tmphQFj8c/oauth-0.99.7/oauth.c:1714: warning: (near initialization for 'oauth_module_entry')
make: *** [oauth.lo] Error 1
ERROR: `make' failed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-09 05:07 UTC] tjerk dot meesters at gmail dot com
This has been fixed since 0.99.8 ;-)
 [2009-05-11 03:07 UTC] jawed@php.net
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/oauth


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Oct 19 10:03:36 2021 UTC