php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58645 No timeout when PDO_4D can't reach the 4D SQL Server
Submitted: 2009-04-23 08:38 UTC Modified: 2009-04-29 06:28 UTC
From: php at 4d dot fr Assigned: splanquart (profile)
Status: Closed Package: PDO_4D (PECL)
PHP Version: 5.2.6 OS: Mac OS X Server 10.5.6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: php at 4d dot fr
New email:
PHP Version: OS:

 

 [2009-04-23 08:38 UTC] php at 4d dot fr
Description:
------------
This problem block all PHP script response if trying to connect a 4D SQL Server which is stopped or called from a wrong address, even in a try catch block.

Reproduce code:
---------------
$dbh = new PDO('4D:host=127.0.0.2', 'test', 'test');

Expected result:
----------------
it should be stop after timedout and provide an error with an SQLSTATE like :

08S01 	Communication link failure


Actual result:
--------------
infinite wait

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-04-29 06:27 UTC] dams@php.net
Timeout support is provided since version PDO_4D-0.2.0.

Please, try this newer version.
 [2009-04-29 06:28 UTC] dams at nexen dot net
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/PDO_4D


 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Nov 19 12:01:26 2018 UTC