php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58628 Problem with pecl build
Submitted: 2009-04-10 03:47 UTC Modified: 2010-11-23 09:39 UTC
From: meganuke at meganuke dot ru Assigned:
Status: Not a bug Package: sphinx (PECL)
PHP Version: 5.2.8 OS: FreeBSD 6.3, FreeBSD 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: meganuke at meganuke dot ru
New email:
PHP Version: OS:

 

 [2009-04-10 03:47 UTC] meganuke at meganuke dot ru
Description:
------------
cd /usr/ports/textproc/sphinxsearch; make install clean
pecl install sphinx

returns

checking whether gcc and cc understand -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... yes
checking build system type... i386-unknown-freebsd7.1
checking host system type... i386-unknown-freebsd7.1
checking target system type... i386-unknown-freebsd7.1
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/lib/php/20060613
checking for PHP installed headers prefix... /usr/local/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... re2c
checking for re2c version... 0.13.5 (ok)
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking for sphinx support... yes, shared
checking for libsphinxclient headers in default path... not found
configure: error: Cannot find libsphinxclient headers
ERROR: `/tmp/sphinx/configure --with-sphinx' failed



Expected result:
----------------
normal build ;)

Actual result:
--------------
unnormal build

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-04-10 04:43 UTC] meganuke at meganuke dot ru
Path to sphinxclient.h
in linux
/usr/local/include/
in FreeBSD
/usr/local/share/examples/sphinxsearch/api/libsphinxclient/
 [2009-04-10 07:21 UTC] tony at daylessday dot org
Use --with-sphinx=<install prefix> or get a working OS.
 [2010-08-08 13:31 UTC] PandoraBox2007 at gmail dot com
checking for libsphinxclient headers in /usr/local/share/examples/sphinxsearch/api/libsphinxclient/... not found
configure: error: Cannot find libsphinxclient headers
ERROR: `/tmp/go-pear/sphinx/configure --with-sphinx=/usr/local/share/examples/sphinxsearch/api/libsphinxclient/' failed
 [2010-08-08 13:33 UTC] PandoraBox2007 at gmail dot com
# ls -lh /usr/local/share/examples/sphinxsearch/api/libsphinxclient/
total 1066
-r--r--r--  1 root  wheel    25K Jul 15  2008 COPYING
-r--r--r--  1 root  wheel   335B Jul 15  2008 Makefile.am
-r--r--r--  1 root  wheel    19K Oct 31  2008 Makefile.in
-r--r--r--  1 root  wheel   1.4K Jul  9  2008 README
-r--r--r--  1 root  wheel   1.1K Jul 15  2008 build.mk
-r--r--r--  1 root  wheel   640B Jul  9  2008 buildconf.sh
-r--r--r--  1 root  wheel    41K Aug  8 20:29 config.guess
-r--r--r--  1 root  wheel    30K Aug  8 20:29 config.sub
-r--r--r--  1 root  wheel   637K Oct 31  2008 configure
-r--r--r--  1 root  wheel   1.6K Oct 31  2008 configure.in
-r--r--r--  1 root  wheel   9.0K Oct 31  2008 install-sh
-r--r--r--  1 root  wheel   3.5K Jul  9  2008 libsphinxclient.vcproj
-r--r--r--  1 root  wheel   179K Oct 31  2008 ltmain.sh
-r--r--r--  1 root  wheel    10K Oct 31  2008 missing
-r--r--r--  1 root  wheel    53K Nov 14  2009 sphinxclient.c
-r--r--r--  1 root  wheel   7.5K Nov 14  2009 sphinxclient.h
-r--r--r--  1 root  wheel   1.5K Oct 31  2008 sphinxclient_config.h.in
-r--r--r--  1 root  wheel   5.7K Nov 14  2009 test.c
-r--r--r--  1 root  wheel   1.5K Jul  9  2008 test.sln
-r--r--r--  1 root  wheel   3.7K Jul  9  2008 test.vcproj
 [2010-08-11 03:58 UTC] santiago739 at gmail dot com
At first, you have to install libsphinxclient on your system. Then you need to specify the path to the directory where your library and headers are installed.
 [2010-08-19 14:17 UTC] PandoraBox2007 at gmail dot com
checking for libsphinxclient headers in /usr/local/share/examples/sphinxsearch/api/libsphinxclient/... not found
configure: error: Cannot find libsphinxclient headers
ERROR: `/tmp/go-pear/sphinx/configure --with-sphinx=/usr/local/share/examples/sphinxsearch/api/libsphinxclient/' failed
 [2010-08-20 01:21 UTC] santiago739 at gmail dot com
Did you install libsphinxclient before?
I suppose not because 
/usr/local/share/examples/sphinxsearch/api/libsphinxclient/ is a path to 
the directory with your libsphinxclient sources.
In order to install libsphinxclient you need to do:

./configure
make
make install

from /usr/local/share/examples/sphinxsearch/api/libsphinxclient/
And then specify path to INSTALLED libsphinxclient for --with-sphinx
 [2010-11-04 19:22 UTC] junk at beroux dot com
I tried the ./configure from the "./api/libsphinxclient" 
directory but it gave an ugly error. Version 0.9.9 and 1.10 
beta both gave errors.

Now doing ./configure and make install worked perfectly in the 
"." directory (place where the source was extracted).

The issue with headers remains. Using Ubuntu 10.04
 [2010-11-09 12:24 UTC] santiago739 at gmail dot com
Please provide a text of error when it happens if it's 
possible.
 [2010-11-21 04:30 UTC] jay at grooveshark dot com
I'm having the same problem in Centos5

I can't install libsphinxclient because make is failing:

 make
make  all-am
make[1]: Entering directory `/tmp/sphinx-0.9.9/api/libsphinxclient'
/bin/sh ./libtool --mode=compile --tag=CC gcc -DHAVE_CONFIG_H -I. -I. -I.     -g -O2 -c -o sphinxclient.lo sphinxclient.c
mkdir .libs
 gcc -DHAVE_CONFIG_H -I. -I. -I. -g -O2 -c sphinxclient.c  -fPIC -DPIC -o .libs/sphinxclient.o
sphinxclient.c:1217: error: static declaration of 'sock_close' follows non-static declaration
sphinxclient.c:280: error: previous declaration of 'sock_close' was here
make[1]: *** [sphinxclient.lo] Error 1
make[1]: Leaving directory `/tmp/sphinx-0.9.9/api/libsphinxclient'
make: *** [all] Error 2


So when I try to run ./configure on the pecl ext, I get the error:
./configure --with-sphinx=/tmp/sphinx-0.9.9/api/libsphinxclient/
...
checking for sphinx support... yes, shared
checking for libsphinxclient headers in /tmp/sphinx-0.9.9/api/libsphinxclient/... not found
configure: error: Cannot find libsphinxclient headers
 [2010-11-23 09:39 UTC] santiago739 at gmail dot com
This bug is not related with sphinx extension. 
It's known issue in libsphinxclient (see 
http://sphinxsearch.com/bugs/view.php?id=468)
AFAIK it was fixed in sphinx svn repo.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 20 00:01:24 2020 UTC