php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58624 Can't install WBXML
Submitted: 2009-04-08 07:25 UTC Modified: 2009-12-11 15:44 UTC
From: akononyhin at list dot ru Assigned:
Status: Not a bug Package: WBXML (PECL)
PHP Version: 5.2.5 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: akononyhin at list dot ru
New email:
PHP Version: OS:

 

 [2009-04-08 07:25 UTC] akononyhin at list dot ru
Description:
------------
I have libwbxml 0.10.5 installed.

When I try to install WBXML by PECL installer (pecl install WBXML) I receive an error while compiling wbxml.c


After some investigation I've found that HAVE_EXPAT is defined but expat.h haven't been included anywhere.


Reproduce code:
---------------
pecl install WBXML

Expected result:
----------------
Successfully installed

Actual result:
--------------
...
In file included from /usr/local/include/wbxml.h:388,
                 from /tmp/tmp6AnxJ9/wbxml-1.0.3/wbxml.c:31:
/usr/local/include/wbxml_tree.h:120: error: expected specifier-qualifier-list before 'XML_Parser'
In file included from /usr/local/include/wbxml.h:390,
                 from /tmp/tmp6AnxJ9/wbxml-1.0.3/wbxml.c:31:
/usr/local/include/wbxml_tree_clb_xml.h:57: error: expected ';', ',' or ')' before '*' token
/usr/local/include/wbxml_tree_clb_xml.h:68: error: expected ';', ',' or ')' before '*' token
/usr/local/include/wbxml_tree_clb_xml.h:78: error: expected ';', ',' or ')' before '*' token
/usr/local/include/wbxml_tree_clb_xml.h:85: error: expected ';', ',' or ')' before '*' token
/usr/local/include/wbxml_tree_clb_xml.h:105: error: expected ';', ',' or ')' before '*' token
/usr/local/include/wbxml_tree_clb_xml.h:114: error: expected ';', ',' or ')' before '*' token
make: *** [wbxml.lo] Error 1
ERROR: `make' failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-04-10 00:59 UTC] fickledreams at yahoo dot com
Having the same problem...even tried compiling the other versions (1.0.0, 1.0.1 and 1.0.2) myself but still the same error.
 [2009-05-26 12:08 UTC] pecl dot php dot net at matveyev dot net
Have the same problem.
 [2009-11-29 05:58 UTC] mikael at synd dot info
I can't reproduce this problem.

From the error message it seems that the problem is with the libwbxml2 header files themselves, you might want to try to upgrade your libwbxml2 version and see if that solves the problem.

If the problem persists in your environment and you could cobble together a patch which fixes it, I'd be happy to apply it.
 [2009-12-11 09:26 UTC] aalmenar at gmailc dot om
Are you trying to compile it on a 64-bit (x86_64) Linux box ?
 [2009-12-11 11:59 UTC] mikael at synd dot info
[mikl@firefly ~]$ uname -a
Linux firefly 2.6.27.10-desktop-1mnb #1 SMP Thu Jan 29 11:16:18 EST 2009 x86_64 Pentium(R) Dual-Core  CPU      E5200  @ 2.50GHz GNU/Linux
[mikl@firefly ~]$ cat /etc/redhat-release 
Mandriva Linux release 2009.0 (Official) for x86_64
 [2009-12-11 15:39 UTC] akononyhin at list dot ru
I can reproduce the problem right now.

Version of my OS:
=====================
[root@sip alex]# uname -a
Linux ...... 2.6.21.7-5.fc8xen #1 SMP Thu Aug 7 12:44:49 EDT 2008 i686 athlon i386 GNU/Linux
[root@sip alex]# cat /etc/redhat-release 
Fedora release 8 (Werewolf)

Version of libwbxml - 0.10.1
Version of WBXML pecl package : 1.0.3


Result of 'pecl install WBXML':
==============================
...
 gcc -I. -I/tmp/pear/download/wbxml-1.0.3 -DPHP_ATOM_INC -I/var/tmp/pear-build-konon/wbxml-1.0.3/include -I/var/tmp/pear-build-konon/wbxml-1.0.3/main -I/tmp/pear/download/wbxml-1.0.3 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -I/usr/local/include -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/download/wbxml-1.0.3/wbxml.c  -fPIC -DPIC -o .libs/wbxml.o
In file included from /usr/local/include/wbxml.h:387,
                 from /tmp/pear/download/wbxml-1.0.3/wbxml.c:31:
/usr/local/include/wbxml_tree.h:120: error: expected specifier-qualifier-list before 'XML_Parser'
In file included from /usr/local/include/wbxml.h:389,
                 from /tmp/pear/download/wbxml-1.0.3/wbxml.c:31:
/usr/local/include/wbxml_tree_clb_xml.h:57: error: expected ';', ',' or ')' before '*' token
/usr/local/include/wbxml_tree_clb_xml.h:68: error: expected ';', ',' or ')' before '*' token
/usr/local/include/wbxml_tree_clb_xml.h:78: error: expected ';', ',' or ')' before '*' token
/usr/local/include/wbxml_tree_clb_xml.h:85: error: expected ';', ',' or ')' before '*' token
/usr/local/include/wbxml_tree_clb_xml.h:105: error: expected ';', ',' or ')' before '*' token
/usr/local/include/wbxml_tree_clb_xml.h:114: error: expected ';', ',' or ')' before '*' token
make: *** [wbxml.lo] Error 1
ERROR: `make' failed
 [2009-12-11 15:44 UTC] akononyhin at list dot ru
The way I  use to resolve this problem:

1) Download the package (instead of install)
2) ./configure
3) open config.h and add the next code after  #define HAVE_EXPAT 1

        #if defined(HAVE_EXPAT)
        #include <expat.h>
        #endif

4) make
5) make install
 [2013-03-05 12:24 UTC] vadim-mishkin at yandex dot ru
Solution of the problem:

1) wget http://pecl.php.net/get/wbxml-1.0.3.tgz
2) tar xvfz wbxml-1.0.3.tgz
3) cd wbxml-1.0.3
4) phpize
5) ./configure 
6) open config.h and add the next code after #define HAVE_EXPAT 1
#if defined(HAVE_EXPAT)
#include <expat.h>
#endif
7) make
8) make install
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Aug 12 13:01:26 2020 UTC