php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58597 Can't install DTrace
Submitted: 2009-03-24 07:53 UTC Modified: 2013-10-23 00:11 UTC
From: murlock42 at gmail dot com Assigned:
Status: Wont fix Package: DTrace (PECL)
PHP Version: 5.2.8 OS: OpenSolaris 2008.11
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: murlock42 at gmail dot com
New email:
PHP Version: OS:

 

 [2009-03-24 07:53 UTC] murlock42 at gmail dot com
Description:
------------
On a full updated OpenSolaris ( repository dev ), I can't install DTrace package with pecl, there is an error compile.

Reproduce code:
---------------
# pecl install dtrace
[...]
creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/sh /var/tmp/pear-build-murlock/dtrace-1.0.3/libtool --mode=compile /usr/bin/gcc  -I. -I/var/tmp/pear/cache/dtrace-1.0.3 -DPHP_ATOM_INC -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/var/tmp/pear-build-murlock/dtrace-1.0.3/include -I/var/tmp/pear-build-murlock/dtrace-1.0.3/main -I/var/tmp/pear/cache/dtrace-1.0.3 -I/usr/php/5.2/include/php -I/usr/php/5.2/include/php/main -I/usr/php/5.2/include/php/TSRM -I/usr/php/5.2/include/php/Zend -I/usr/php/5.2/include/php/ext -I/usr/php/5.2/include/php/ext/date/lib  -I/usr/php/5.2/include/php -DHAVE_CONFIG_H  -g -O2   -c /var/tmp/pear/cache/dtrace-1.0.3/dtrace.c -o dtrace.lo
mkdir .libs
 /usr/bin/gcc -I. -I/var/tmp/pear/cache/dtrace-1.0.3 -DPHP_ATOM_INC -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/var/tmp/pear-build-murlock/dtrace-1.0.3/include -I/var/tmp/pear-build-murlock/dtrace-1.0.3/main -I/var/tmp/pear/cache/dtrace-1.0.3 -I/usr/php/5.2/include/php -I/usr/php/5.2/include/php/main -I/usr/php/5.2/include/php/TSRM -I/usr/php/5.2/include/php/Zend -I/usr/php/5.2/include/php/ext -I/usr/php/5.2/include/php/ext/date/lib -I/usr/php/5.2/include/php -DHAVE_CONFIG_H -g -O2 -c /var/tmp/pear/cache/dtrace-1.0.3/dtrace.c  -fPIC -DPIC -o .libs/dtrace.o
In file included from /usr/include/gelf.h:34,
                 from /usr/include/dtrace.h:35,
                 from /var/tmp/pear/cache/dtrace-1.0.3/dtrace.c:31:
/usr/include/libelf.h:44:2: #error "large files are not supported by libelf"
make: *** [dtrace.lo] Error 1
ERROR: `make' failed



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-10-23 00:11 UTC] sixd@php.net
-Status: Open +Status: Wont fix
 [2013-10-23 00:11 UTC] sixd@php.net
DTrace support was merged to core PHP 5.4, and various recent build fixes are in PHP 5.4.20

I'm marking this bug as "Won't fix" because no one is looking after the PECL DTrace package, AFAICT.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Aug 12 07:01:25 2020 UTC