php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58579 No space left on device bug
Submitted: 2009-03-09 12:35 UTC Modified: 2009-03-13 15:56 UTC
From: djonline at djonline dot ru Assigned:
Status: Not a bug Package: APC (PECL)
PHP Version: 5.2.5 OS: FC9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: djonline at djonline dot ru
New email:
PHP Version: OS:

 

 [2009-03-09 12:35 UTC] djonline at djonline dot ru
Description:
------------
[apc-error] apc_sem_create: semget(0,...) failed: No space 
left on device

Server Software	Apache/2.2.9 (Fedora)
Shared Memory	1 Segment(s) with 32.0 MBytes 
(mmap memory, IPC semaphore locking)

 Free: 25.7 MBytes (80.5%)	 Hits: 19369 (99.2%)
 Used: 6.3 MBytes (19.5%)	 Misses: 155 (0.8%)

Bug ?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-03-11 16:09 UTC] shire@php.net
This is likely due to memory constraints on your system, or limitations on semaphores, not actually running out of APC cache space.

I would suggest, that you use pthread locking (default in the latest version) or spin locking (more experimental).  These shouldn't have the constraints you're seeing here and are preferred for your OS.  Let us know if these options cause problems for you.
 [2009-03-13 10:04 UTC] djonline at djonline dot ru
Yes, now I user pthread locking.
But it is time to add information about semaphore 
limitations in FAQ, INSTALL and documentation APC.
There is nothing about new features in manual too (added 
with version 3.0.11).
 [2009-03-13 15:56 UTC] shire@php.net
Yep, the documentation needs some updates and is on our list of things todo.  Thanks.
 [2009-04-21 15:43 UTC] emil at stoynev dot us
Hello, I have the same problem, same situation, How can I fix it?

Thank you.

OS: FreeBSD 7.1 
Apache 2.2 , PECL/APC-3.0.19
 [2009-04-21 16:46 UTC] emil at stoynev dot us
I fixed it, done.

Thanks.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Jul 27 18:01:26 2021 UTC