php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58572 http.so: undefined symbol: SEPARATE_ARG_IF_REF
Submitted: 2009-03-02 23:04 UTC Modified: 2009-03-10 12:26 UTC
From: peclbug at pnetsolns dot com Assigned: mike (profile)
Status: Closed Package: pecl_http (PECL)
PHP Version: 4.4.8 OS: Debian Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: peclbug at pnetsolns dot com
New email:
PHP Version: OS:

 

 [2009-03-02 23:04 UTC] peclbug at pnetsolns dot com
Description:
------------
I recently attempted to add pecl_http to our PHP 4.4.9 (which wasn't in the "PHP version" pull-down menu above so I chose 4.4.8) environment but it seems to cause apache (1.3.41) to crash with the following error:

/usr/local/4admin/apache/bin/httpsd: symbol lookup error: /usr/local/4admin/apache/lib/php/extensions/no-debug-non-zts-20020429/http.so: undefined symbol: SEPARATE_ARG_IF_REF

Here is my PHP configure line:
./configure --enable-mailparse --with-mysql=/usr --with-apache=../apache_1.3.41 --with-curl --with-gd --with-jpeg-dir=/usr --with-png-dir=/usr --with-zlib-dir=/usr --with-xpm-dir=/usr --with-freetype-dir=/usr --with-zlib --with-jpeg --with-tiff --with-freetype --with-imap --with-imap-ssl --with-gnu-ld --with-mhash --with-gettext --with-ncurses --with-gmp --with-iconv --with-pspell --with-expat --with-mcrypt --with-openssl --with-xslt-sablot --with-kerberos --with-pdflib=no --with-imagick=/usr/local/4admin/phpstuff --with-pfpro=shared,/usr/local/4admin/phpstuff/verisign/payflowpro/linuxrh9/lib --with-dom --with-dom-xslt --with-mime-magic=/usr/local/4admin/apache/conf/magic --with-fileinfo=shared --with-xsl --with-tidy --enable-bcmath --enable-exif --enable-ftp --enable-trans-sid --enable-yp --enable-wddx --enable-calendar --enable-dbx --enable-dio --enable-mcal --enable-track-vars --enable-module=so --enable-mbstring=all --enable-xslt --enable-dbase --prefix=/usr/local/4admin/apache --exec-prefix=/usr/local/4admin/apache

I suspect the problem is that "SEPARATE_ARG_IF_REF" only exists in Zend Engine 2 which implies that pecl_http is no longer supported in PHP 4.x (which I realize has been EOL'ed).  If that is the case then the Dependecies section of the pecl_http page should be updated.

BTW, it looks like SEPARATE_ARG_IF_REF only recently appeared in the newest versions (>1.90) of php_http_api.c:
http://cvs.php.net/viewvc.cgi/pecl/http/php_http_api.h?r1=1.90&r2=1.91

Please let me know if you need any additional information.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-03-03 02:38 UTC] mike@php.net
It is an oversight.

Thank you.
 [2009-03-10 12:26 UTC] mike@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Oct 18 21:03:39 2021 UTC