php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58520 Apache stops responding
Submitted: 2009-01-26 13:28 UTC Modified: 2009-01-29 04:43 UTC
From: andrzej at kreolabs dot com Assigned:
Status: Duplicate Package: APC (PECL)
PHP Version: 5.1.6 OS: RHEL 5.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: andrzej at kreolabs dot com
New email:
PHP Version: OS:

 

 [2009-01-26 13:28 UTC] andrzej at kreolabs dot com
Description:
------------
We have recently upgraded our websites from php 4.4 + apache 
1.3 + apc 3.0.10 to the new server running on php 5.1.6 + 
apache 2 + apc 3.0.19 (latest stable).

Since then, about once a week (randomly) apache server 
encounter a strange crash causing it not to respond to any 
http request. The only solution seems to be full apache 
restart - which instantly fix the issue.

gdb backtrace from one of the http processed attached (see 
below)

Do you have any idea what could have caused this issue? Like I 
said, we experience it very regularly now - at least once per 
week... 

Actual result:
--------------
0x00002b873e913888 in __lll_mutex_lock_wait () from 
/lib64/libpthread.so.0
#0  0x00002b873e913888 in __lll_mutex_lock_wait () from 
/lib64/libpthread.so.0
No symbol table info available.
#1  0x00002b873e90f8a5 in _L_mutex_lock_107 () from 
/lib64/libpthread.so.0
No symbol table info available.
#2  0x00002b873e90f333 in pthread_mutex_lock () from 
/lib64/libpthread.so.0
No symbol table info available.
#3  0x00002b874b057479 in apc_pthreadmutex_lock 
(lock=0x2b877095b110) at /usr/local/src/APC-
3.0.19/apc_pthreadmutex.c:72
        result = <value optimized out>
#4  0x00002b874b051b46 in apc_cache_user_find 
(cache=0x2b873cea7cd0, strkey=0x2b874acfbd28 
"yeego2_SiteConfig", keylen=1049716792, t=1232993043)
    at /usr/local/src/APC-3.0.19/apc_cache.c:579
        slot = <value optimized out>
#5  0x00002b874b04fb6d in zif_apc_fetch (ht=<value optimized 
out>, return_value=0x2b874acfbd68, return_value_ptr=<value 
optimized out>,
    this_ptr=<value optimized out>, return_value_used=<value 
optimized out>) at /usr/local/src/APC-3.0.19/php_apc.c:706
        key = (zval *) 0x2b874acfbce8
        success = (zval *) 0x0
        hash = <value optimized out>
        hpos = (HashPosition) 0x7fff6dca1500
        hentry = <value optimized out>
        result = <value optimized out>
        result_entry = <value optimized out>
        strkey = 0x0 
        strkey_len = -4
        entry = <value optimized out>
        t = 1232993043 
#6  0x00002b87486cdfa2 in execute () from 
/etc/httpd/modules/libphp5.so
No symbol table info available.
#7  0x00002b87486be10c in execute () from 
/etc/httpd/modules/libphp5.so
No symbol table info available.
#8  0x00002b87486c3d0e in execute () from 
/etc/httpd/modules/libphp5.so
No symbol table info available.
#9  0x00002b87486be10c in execute () from 
/etc/httpd/modules/libphp5.so
No symbol table info available.
#10 0x00002b87486a11de in zend_execute_scripts () from 
/etc/httpd/modules/libphp5.so
No symbol table info available.
#11 0x00002b87486662c7 in php_execute_script () from 
/etc/httpd/modules/libphp5.so
No symbol table info available.
#12 0x00002b874871e6c6 in php_ap2_register_hook () from 
/etc/httpd/modules/libphp5.so
No symbol table info available.
#13 0x00002b873ce2c7ea in ap_run_handler () from 
/usr/sbin/httpd
No symbol table info available.
#14 0x00002b873ce2fc62 in ap_invoke_handler () from 
/usr/sbin/httpd
No symbol table info available.
#15 0x00002b873ce3a618 in ap_process_request () from 
/usr/sbin/httpd
No symbol table info available.
#16 0x00002b873ce378a0 in ap_register_input_filter () from 
/usr/sbin/httpd
No symbol table info available.
#17 0x00002b873ce33a42 in ap_run_process_connection () from 
/usr/sbin/httpd
No symbol table info available.
#18 0x00002b873ce3e22b in ap_graceful_stop_signalled () from 
/usr/sbin/httpd
No symbol table info available.
#19 0x00002b873ce3e4ba in ap_graceful_stop_signalled () from 
/usr/sbin/httpd
No symbol table info available.
#20 0x00002b873ce3ed1d in ap_mpm_run () from /usr/sbin/httpd
No symbol table info available.
#21 0x00002b873ce19e04 in main () from /usr/sbin/httpd
No symbol table info available.
Saved corefile core.19236





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-26 13:31 UTC] andrzej at kreolabs dot com
my APC settings

apc.cache_by_default	1
apc.coredump_unmap	0
apc.enable_cli	1
apc.enabled	1
apc.file_update_protection	2
apc.filters	
apc.gc_ttl	3600
apc.include_once_override	0
apc.max_file_size	1M
apc.mmap_file_mask	/tmp/apc.V0O3ia
apc.num_files_hint	1024
apc.report_autofilter	0
apc.shm_segments	1
apc.shm_size	512
apc.slam_defense	0
apc.stat	1
apc.stat_ctime	0
apc.ttl	7200
apc.user_entries_hint	4096
apc.user_ttl	7200
apc.write_lock	1
 [2009-01-29 04:43 UTC] andrzej at kreolabs dot com
after some more investigation I have found out that this is 
most likely a duplicate to the following:

http://pecl.php.net/bugs/bug.php?id=14061
http://pecl.php.net/bugs/bug.php?id=13445

.. and was caused by way too many user entries in the cache 
- which took too long to clear when apc_clear_cache was 
called...
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Aug 01 07:01:25 2021 UTC