php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58509 incorrect internal iconv conversion to ucs-2
Submitted: 2009-01-14 12:08 UTC Modified: 2013-11-11 11:06 UTC
From: soltpain at gmail dot com Assigned:
Status: Duplicate Package: translit (PECL)
PHP Version: Irrelevant OS: FreeBSD 7.1, Windows 2003
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: soltpain at gmail dot com
New email:
PHP Version: OS:

 

 [2009-01-14 12:08 UTC] soltpain at gmail dot com
Description:
------------
Inner conversion to ucs-2 routune is not correct on several OS'es, call to php_iconv_string(... 'ucs-2') may be result data in Big Endian or Lower Indian byte order depending on OS, i assume.

Processing functions are working with data in LE byte order.

Reproduce code:
---------------
To fix, replace in php_iconv_string calls 'ucs-2' to 'ucs-2le'.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-11-11 11:06 UTC] derick@php.net
-Status: Open +Status: Duplicate
 [2013-11-11 11:06 UTC] derick@php.net
This is a duplicate of 58159, for which I've just committed a fix.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon May 20 08:01:26 2019 UTC