php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58426 error when executing pecl install pdo
Submitted: 2008-11-24 07:21 UTC Modified: 2017-03-01 22:35 UTC
From: vidhyahsbc at gmail dot com Assigned:
Status: Wont fix Package: PDO Core
PHP Version: 5.2.5 OS: centos 5.2 i686 on standard
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: vidhyahsbc at gmail dot com
New email:
PHP Version: OS:

 

 [2008-11-24 07:21 UTC] vidhyahsbc at gmail dot com
Description:
------------
i get the error when i execute 
pecl install pdo.

i could not find the config.log file also....



Reproduce code:
---------------
/root$ pecl install pdo
downloading PDO-1.0.3.tgz ...
Starting to download PDO-1.0.3.tgz (52,613 bytes)
.............done: 52,613 bytes
12 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
building in /var/tmp/pear-build-root/PDO-1.0.3
running: /root/tmp/pear/temp/PDO/configure
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.
ERROR: `/root/tmp/pear/temp/PDO/configure' failed



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-12-13 12:01 UTC] helgith at gmail dot com
reassigned to proper package
 [2009-07-13 11:57 UTC] ladadadada at hotmail dot com
The problem is most likely that your system (Probably RedHat or RedHat based) has /tmp mounted as noexec.  It also has /var/tmp symlinked to /tmp.

The configure script tries to build a simple compiled C program in /tmp regardless of the PECL config and then can't execute it due to the noexec option.  It chooses this directory during the phpize step and the value comes from the config.guess file.

The config.log file is deleted by the pecl script right after it prints out the error.

The easiest way to make it work is either to symlink the appropriate directory somewhere else or remount /tmp.
 [2017-03-01 22:35 UTC] adambaratz@php.net
-Status: Open +Status: Wont fix -Package: PDO +Package: PDO Core
 [2017-03-01 22:35 UTC] adambaratz@php.net
PDO has been moved out of Pecl.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu May 13 08:01:24 2021 UTC