php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58397 Superseded by feature not working
Submitted: 2008-10-28 22:20 UTC Modified: 2012-12-31 03:17 UTC
From: philip@php.net Assigned: tyrael (profile)
Status: Closed Package: PECL website (PECL)
PHP Version: Irrelevant OS: Mac
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: philip@php.net
New email:
PHP Version: OS:

 

 [2008-10-28 22:20 UTC] philip@php.net
Description:
------------
When editing a package (via package-edit.php) and attempting to supersede one package with another (via the Superseded by: dropdown) it does not save despite saying "Package information successfully updated." after submit.

And while testing, consider superseding classkit with runkit.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-12-31 03:17 UTC] tyrael@php.net
The fix for this bug has been committed.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.

there were a duplicated input with the same name as the superseded dropdown, and 
that overwrite the selection of the dropdown.
I've removed it, so after the code get synced it should work as intended.

ps: I've also debuged from the code, that there is an option to display a link for 
the superseded package, but for that to be displayed, you have to put pecl.php.net 
to the 'New home link' field.
You can see that in action on the classkit package.
 [2012-12-31 03:17 UTC] tyrael@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: tyrael
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jun 21 21:01:23 2021 UTC