php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58382 configure: error: wrong idn lib version or lib not found
Submitted: 2008-10-16 14:40 UTC Modified: 2009-01-20 15:24 UTC
From: nitefall at box201 dot com Assigned:
Status: Not a bug Package: idn (PECL)
PHP Version: 5_2 CVS-2008-10-16 (dev) OS: freebsd 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nitefall at box201 dot com
New email:
PHP Version: OS:

 

 [2008-10-16 14:40 UTC] nitefall at box201 dot com
Description:
------------
Failed to download pecl/idn within preferred state "stable", latest release is version 0.1, stability "beta", use "channel://pecl.php.net/idn-0.1" to install
Cannot initialize 'channel://pecl.php.net/idn', invalid or missing package file
downloading idn-0.1.tar ...
Starting to download idn-0.1.tar (Unknown size)
........done: 20,992 bytes
Package "channel://pecl.php.net/idn" is not valid
3 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
 1. GNU libidn installation dir? : autodetect

1-1, 'all', 'abort', or Enter to continue:
building in /var/tmp/pear-build-bduke/idn-0.1
running: /tmp/download/idn-0.1/configure --with-idn
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for a sed that does not truncate output... /usr/bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc and cc understand -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... yes
checking build system type... i386-unknown-freebsd6.2
checking host system type... i386-unknown-freebsd6.2
checking target system type... i386-unknown-freebsd6.2
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/lib/php/20060613
checking for PHP installed headers prefix... /usr/local/include/php
checking for re2c... re2c
checking for re2c version... 0.13.5 (ok)
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking for idn support... yes, shared
checking for idn files in default path... checking for stringprep_check_version in -lidn... no
configure: error: wrong idn lib version or lib not found
ERROR: `/tmp/download/idn-0.1/configure --with-idn' failed


Reproduce code:
---------------
>pecl install idn channel://pecl.php.net/idn-0.1

Expected result:
----------------
install successful

Actual result:
--------------
stringprep_check_version in -lidn... no
configure: error: wrong idn lib version or lib not found
ERROR: `/tmp/download/idn-0.1/configure --with-idn' failed

p.s. libidn-1.9 is already installed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-16 14:50 UTC] johannes at schlueters dot de
Are you sure your sysem installed the devel files? What's the path of idna.h on the system? (should be /usr/include/idna.h o similar)
 [2009-01-20 15:24 UTC] jan at horde dot org
Duplicate of bug #11768.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 10:03:34 2021 UTC