php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58358 kkk
Submitted: 2008-10-01 08:54 UTC Modified: 2009-03-06 01:10 UTC
From: changrh at ccu dot edu dot tw Assigned:
Status: Closed Package: PDO_INFORMIX (PECL)
PHP Version: 5.2.5 OS: windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: changrh at ccu dot edu dot tw
New email:
PHP Version: OS:

 

 [2008-10-01 08:54 UTC] changrh at ccu dot edu dot tw
Description:
------------
source code :

<?php

require_once('./config.php');


$table = 'texttest';
$test_num = '26';
$test_name = 'content~~~~~~~~';

COMM_utf8_to_big5($test_num);
COMM_utf8_to_big5($test_name);

		try{
			//?????ɘA??
		
			$ls_sql = "insert into " . $table . " values(
										:test_num, 
										:test_name 
									)";
			$sth = $dbh->prepare($ls_sql);
			
			$sth->bindParam(1, $test_num);																		
			$sth->bindParam(2, $test_name,PDO::PARAM_STR);	
			
			$rtn = $sth->execute(array(':test_num' => $test_num, ':test_name' => $test_name));
if ($rtn)
echo "{success:true, kind:'add'}";
	else
echo "{success:false, data:'".json_encode($sth->errorInfo())."'}";}
catch (Exception $e){
$err = $e->getMessage();
echo "{success:false, data:'$err'}";	}
?>



Reproduce code:
---------------
{ODBC Driver][Informix]Illegal attempt to convert Text\/Byte 

Expected result:
----------------
{success:false, data:'["HY000",-608,"[Informix][Informix ODBC Driver][Informix]Illegal attempt to convert Text\/Byte blob type. (SQLExecute[-608] at ..\\pecl\\pdo_informix\\informix_statement.c:733)"]'}

Actual result:
--------------
{success:false, data:'["HY000",-608,"[Informix][Informix ODBC Driver][Informix]Illegal attempt to convert Text\/Byte blob type. (SQLExecute[-608] at ..\\pecl\\pdo_informix\\informix_statement.c:733)"]'}

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-06 06:51 UTC] abhargav at in dot ibm dot com
Hi,

First of all sorry for late response (I was on vacation).

Now, it looks like "Expected result" and "Actual result" are same. Can you explain the problem that you are facing? 

Also please send the CREATE TABLE statement to reproduce the problem and details about COMM_utf8_to_big5 function.

regards,
Ambrish Bhargava.
 [2009-03-06 01:10 UTC] abhargav at in dot ibm dot com
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jun 17 14:01:28 2019 UTC