php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58327 Segfault with latest php5.3 snapshot
Submitted: 2008-08-26 08:53 UTC Modified: 2008-08-26 10:08 UTC
From: s dot tretter at szene1 dot at Assigned:
Status: Duplicate Package: APC (PECL)
PHP Version: 5_3 CVS-2008-08-26 (dev) OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
46 - 19 = ?
Subscribe to this entry?

 
 [2008-08-26 08:53 UTC] s dot tretter at szene1 dot at
Description:
------------
- apc 3.0.19
- just use apc_fetch and apc_put.. i always get a segfault with the latest cvs snapshot.. (10:30) the snapshot before 08:30 still works!
- './configure' \
'--with-pcre-regex' \
'--without-sqlite' \
'--with-mysqli=mysqlnd' \
'--with-gd' \
'--with-ttf' \
'--enable-exif' \
'--with-mcrypt' \
'--enable-mbstring' \
'--enable-spl' \
'--prefix=/usr/local/php5' \
'--with-zlib' \
'--enable-gd-native-ttf' \
'--enable-sockets' \
'--enable-soap' \
'--with-apxs2=/usr/local/apache2/bin/apxs' \
'--enable-debug' \
"$@"
- also have memcached module for php
- php.ini is not special,.. i could relevant part for apc:
extension=apc.so
apc.shm_size=128
;apc.enable_cli=1
apc.rfc1867=1
;apc.filters=NULL
;apc.enabled=1
apc.report_autofilter=1
apc.stat=1
apc.num_files_hint=100
apc.user_entries_hint=3200
apc.localcache=0
apc.localcache.size=50
apc.include_once_override=1
;apc.user_ttl = 900
;apc.ttl = 3600
apc.write_lock=1

Reproduce code:
---------------
just use apc_fetch or apc_get 

Expected result:
----------------
no segfault ;)

Actual result:
--------------
backtrace: 0xb709f05e in apc_op_ZEND_INCLUDE_OR_EVAL (execute_data=0xce) at /root/szene1_v3/APC-3.0.19/apc_zend.c:144
144             APC_ZEND_OPLINE


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-26 09:52 UTC] s dot tretter at szene1 dot at
and the segfault only happens when the script is executed by apache2 (mod_php5)...
if i start php via cli .. no seg fault occures!
 [2008-08-26 10:01 UTC] s dot tretter at szene1 dot at
sorry... my fault, also happens with cli version of php..the apc.enable_cli=1 flag was missing ;)

here a backtrace from cli:
(gdb) run
Starting program: /usr/local/php5/bin/php index.php
[Thread debugging using libthread_db enabled]
[New Thread -1211750736 (LWP 1026)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1211750736 (LWP 1026)]
0xb7bad527 in apc_op_ZEND_INCLUDE_OR_EVAL (execute_data=0xafb46ca0) at /root/../APC-3.0.19/apc_zend.c:216
216                     ret = apc_original_opcode_handlers[APC_OPCODE_HANDLER_DECODE(opline)](ZEND_OPCODE_HANDLER_ARGS_PASSTHRU);
 [2008-08-26 10:08 UTC] s dot tretter at szene1 dot at
solution found, bug #7141 reported that it only works with include_once_override=0... this works for me ;)

although anyone should fix this.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Sep 19 12:03:36 2021 UTC