php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58286 Cannot Compile
Submitted: 2008-07-23 19:31 UTC Modified: 2008-12-02 16:58 UTC
From: raky at intabill dot com Assigned: mikesul (profile)
Status: Closed Package: ssh2 (PECL)
PHP Version: 5_3 CVS-2008-07-23 (dev) OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: raky at intabill dot com
New email:
PHP Version: OS:

 

 [2008-07-23 19:31 UTC] raky at intabill dot com
Description:
------------
Hey Guys, 

I'm running a 64bit version of RHEL 4.0 and recently upgraded PHP to use PHP 5.3dev. 

Ever since the upgrade, I have been unable to get the ssh2 module to compile. I have tried the necessary patches, and they still seem to not work. 

Any ideas would be great, the error I receive is below:

Reproduce code:
---------------
/root/installs/ssh2-0.10/ssh2.c: In function `zif_ssh2_poll':
/root/installs/ssh2-0.10/ssh2.c:892: error: structure has no member named `is_ref'
/root/installs/ssh2-0.10/ssh2.c:892: error: structure has no member named `refcount'
/root/installs/ssh2-0.10/ssh2.c:902: error: structure has no member named `is_ref'
/root/installs/ssh2-0.10/ssh2.c:903: error: structure has no member named `refcount'
/root/installs/ssh2-0.10/ssh2.c: In function `zif_ssh2_publickey_add':
/root/installs/ssh2-0.10/ssh2.c:1012: error: structure has no member named `is_ref'
/root/installs/ssh2-0.10/ssh2.c:1013: error: structure has no member named `refcount'



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-12-02 16:52 UTC] mike at regexia dot com
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Apr 08 06:01:25 2020 UTC