php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58275 intl doesn't support -Wl,--as-needed
Submitted: 2008-07-15 11:48 UTC Modified: 2009-05-23 09:59 UTC
From: nlopess@php.net Assigned:
Status: Closed Package: intl (PECL)
PHP Version: 5_3 CVS-2008-07-15 (dev) OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nlopess@php.net
New email:
PHP Version: OS:

 

 [2008-07-15 11:48 UTC] nlopess@php.net
Description:
------------
This package doesn't support LDFLAGS='-Wl,--as-needed', as can be seen in http://gcov.php.net/viewer.php?version=PHP_5_3&func=compile_results


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-22 16:27 UTC] stas at zend dot com
Don't see the errors anymore, does it still happen?
 [2008-07-22 21:02 UTC] nlopess@php.net
it still happens. I've temporarily disabled the as-needed thing so that it can build. The testing now takes 2 more hours, though.
This is a problem with the linker and can usually be fixed by changing the order of the libraries (-lx).
 [2008-07-23 17:55 UTC] stas at zend dot com
I just added LDFLAGS='-Wl,--as-needed' and it compiled fine for me. Could you describe how this can be reproduced?
 [2008-07-23 23:20 UTC] nlopess@php.net
Well it does compile fine with the standard extensions. You need to enable a few more to make it fail. I haven't tracked what's the other extension that makes it fail, though. The extensions that the gcov machine has enabled can be found at http://gcov.php.net/viewer.php?version=PHP_5_3&func=system
 [2008-08-10 19:19 UTC] nlopess@php.net
so the problem is between this extension and PDO firebird. I think this problem is only reproducible if you enable both.
 [2009-05-23 09:59 UTC] nlopess@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

fixed pdo_firebird config.m4 (at least for the default parameters)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 04:01:24 2020 UTC