php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58230 59
Submitted: 2008-06-11 03:49 UTC Modified: 2013-02-18 00:35 UTC
From: IRuban at luxoft dot com Assigned: jon (profile)
Status: No Feedback Package: perforce (PECL)
PHP Version: 5.2.5 OS: Linux slackware 2.6.24
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: IRuban at luxoft dot com
New email:
PHP Version: OS:

 

 [2008-06-11 03:49 UTC] IRuban at luxoft dot com
Description:
------------
From cmd line the module works fine, but when the php work as apache module the script get SIGTERM inside the $p4->final( );

Server version: Apache/2.2.8 (Unix)
Server built:   Mar 26 2008 11:36:44
Server's Module Magic Number: 20051115:11
Server loaded:  APR 1.2.8, APR-Util 1.2.8
Compiled using: APR 1.2.8, APR-Util 1.2.8
Architecture:   32-bit
Server MPM:     Prefork
  threaded:     no
    forked:     yes (variable process count)
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/prefork"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_SYSVSEM_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D DYNAMIC_MODULE_LIMIT=128
 -D HTTPD_ROOT="/usr/local/apache2"
 -D SUEXEC_BIN="/usr/local/apache2/bin/suexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_LOCKFILE="logs/accept.lock"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"

root@slackware:~# php-config
Usage: /usr/local/bin/php-config [OPTION]
Options:
  --prefix            [/usr/local]
  --includes          [-I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib]
  --ldflags           [ -L/usr/lib/mysql]
  --libs              [-lcrypt   -lcrypt -lresolv -lm -ldl -lnsl  -lxml2 -lz -lm -lmysqlclient -lz -lcrypt -lnsl -lm -lssl -lcrypto -lcrypt -lxml2 -lz -lm -lcrypt ]
  --extension-dir     [/usr/local/lib/php/extensions/no-debug-non-zts-20060613]
  --include-dir       [/usr/local/include/php]
  --php-binary        [/usr/local/bin/php]
  --php-sapis         [cli apache2handler]
  --configure-options [--with-apxs2=/usr/local/apache2/bin/apxs --enable-safe-mode --enable-pdo --disable-cgi --disable-ipv6 --disable-all --with-pdo-mysql --with-pcre-regex --enable-libxml --enable-xml --with-pear]
  --version           [5.2.5]
  --vernum            [50205]


root@slackware:~# pear -V
PEAR Version: 1.6.1
PHP Version: 5.2.5
Zend Engine Version: 2.2.0
Running on: Linux slackware 2.6.24 #5 SMP Thu Apr 10 16:13:08 EEST 2008 i686

p4 api version:
p4api_r0703_linux26.tar


Reproduce code:
---------------
//------------------------------------------
function p4_exe_command( $command, $args )
//------------------------------------------
{
   /* Create the Perforce Client objects. */
   $ui = new ClientUser();
   $p4 = new PerforceClient($ui);

   $p4->setPort('public.perforce.com:1666');
   /* Initialize the Perforce interface. */
   if ( !$p4->init() )
   {
      die( "Failed to initialize Perforce client interface.\n" );
   }

   /* Shut down the Perforce interface. */
   $p4->final( );
}
All ClientUser methods is empty.

Expected result:
----------------
The script have to exit without SIGTERM.

Actual result:
--------------
The script get SIGTERM inside the $p4->final( );
From apache log:
[Wed Apr 16 13:51:09 2008] [notice] caught SIGTERM, shutting down

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-06-12 17:28 UTC] jon@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2013-02-18 00:35 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Thu Sep 28 22:01:24 2023 UTC