php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58208 Problem with installing of ibm_db2 (db2 v9.5, linux FC9)
Submitted: 2008-06-02 09:14 UTC Modified: 2009-03-06 02:49 UTC
From: robert dot prokopczuk at wp dot pl Assigned:
Status: Closed Package: ibm_db2 (PECL)
PHP Version: 5.2.5 OS: Linux FC9
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: robert dot prokopczuk at wp dot pl
New email:
PHP Version: OS:

 

 [2008-06-02 09:14 UTC] robert dot prokopczuk at wp dot pl
Description:
------------
I have a problem with installing of ibm_db2 extension. 

Reproduce code:
---------------
pecl install ibm_db2

Actual result:
--------------
[root@localhost ibm_db2-1.6.5]# ./configure --with-IBM_DB2=/opt/ibm/db2/V9.5
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc and cc understand -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib
checking for PHP extension directory... /usr/lib/php/modules
checking for PHP installed headers prefix... /usr/include/php
checking for re2c... re2c
checking for re2c version... 0.12.3 (ok)
checking for gawk... gawk
checking for IBM_DB2 support... yes, shared
checking Looking for DB2 CLI libraries... checking      in /opt/ibm/db2/V9.5... 
checking      in /opt/ibm/db2/V9.5/lib64... 
checking      in /opt/ibm/db2/V9.5/lib32... found
checking for DB2 CLI include files in default path... checking in /opt/ibm/db2/V9.5... not found
configure: error: Please reinstall the DB2 CLI distribution


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-06-02 11:11 UTC] opendev at us dot ibm dot com
Hi Robert,
Can you let us know which DB2 product you are using. While installing ibm_db2 it searches for the include files in the directory /opt/ibm/db2/V9.5/include, in your case seems like the include directory is not found.Please let us know which product of DB2 are you using, so that we can guide in having ibm_db2 installed. If in case you are using the product DB2 connect then try the steps which Patrick has suggested, if not successful do let us know we will help you

Thank and Regards

Praveen
 [2008-06-03 08:20 UTC] robert dot prokopczuk at wp dot pl
I have installed DB2 v9.5 Express-C, instance owner is user db2 (not db2inst1).

The  directory /opt/ibm/db2/V9.5/include contains file:
asn.h
 [2008-06-03 13:57 UTC] opendev at us dot ibm dot com
Hi Robert,

Seems like your DB2 is not installed properly, could you please re-install it and then check if you are able to build ibm_db2. The directory include should contain many more files like sqlcli1.h, sqlcli.h, sql.h etc. while installing ibm_db2 it finds for DB2 CLI include files in the include directory (to name a few, the files specified above), which it is not able to find.

Thank You
Praveen
 [2008-06-25 10:12 UTC] bricenow at hotmail dot com
Hi,

I find myself in the same position, but in my case, I dont have DB2 installed in my App-Server, wich is the one i will using to connect to the DB-Server.

So What I'm Asking is... Should I install DB on my App-Server just to let PHP connect to a db2 Database ???

Any help you can give me will be nice...

Best Regards,

Wilfredo Brice?o
 [2008-06-27 02:22 UTC] opendev at us dot ibm dot com
Hi Wilfredo,

<<Should I install DB on my App-Server just to
let PHP connect to a db2 Database ???
>>
The answer to this is, No, you need not install the DB on your App-Server. But however you would require a DB2 client (at your app-server), to connect to the Database. There are different types of client namely 'Dataserver Client', 'Dataserver Run-time client' and 'Data Server Driver for ODBC, CLI, and .NET' . You can choose any depending on your requirement. More info on this can be found at http://publib.boulder.ibm.com/infocenter/db2luw/v9r5/topic/com.ibm.db2.luw.qb.client.doc/doc/c0023452.html

Coming to the next part, i.e. getting the PHP DB2 driver binary. This differs based on the platform your app-server is on : - 
What platform is your App-Server on? --

	a) If your App-server is a Linux box, then it will require that you should build the PHP driver. For building the PHP driver the minimum thing that will be required is the DB2 client with the necessary include files. You may also build the PHP driver on your DB server, which will surely have all the minimum requirements, and use the binaries built there on your client side (provided the client and the server platforms are the same).

	b) If your App-server is a windows box then you need not build the PHP driver, the binaries for windows are available from the Pecl-for-windows site http://pecl4win.php.net/list.php  .


Thanks and regards
Praveen
 [2008-08-18 17:31 UTC] nhimmons at sanovia dot com
I have IBM V8.1 on linux and performed the following on the database server and recieved an error. Please advise

[root@palodbt db2]# pecl install ibm_db2
downloading ibm_db2-1.7.0.tgz ...
Starting to download ibm_db2-1.7.0.tgz (131,111 bytes)
.................done: 131,111 bytes
5 source files, building
running: phpize
sh: phpize: command not found
ERROR: `phpize' failed
 [2008-08-19 01:15 UTC] opendev at us dot ibm dot com
Hi,

Seems like your phpize is not configured properly. Please check if you have the appropriate devel version of the php package. More details on phpize http://php.mirrors.ilisys.com.au/manual/en/install.pecl.phpize.php 
Also take a look at this link http://linux.derkeiler.com/Mailing-Lists/Fedora/2004-12/7731.html , even here he was getting the same kind of error and had it solved by installing the appropriate php devel. Let me know if this solves the problem.

Thanks and Regards

Praveen
 [2009-03-06 02:49 UTC] abhargav at in dot ibm dot com
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2013-10-23 14:44 UTC] jhehir11 at aol dot com
I got the same error as Mr. Prokopczuk, albeit working with version DB2 v10.5 AESE.  For me, I'm using the client files in a server installation to access another database server, either way with a basic server installation or 'typical' you will not get the Base Application Development tools installed and this is needed for the client libraries to be present (/include).  Re-run db2setup and 'work with existing installation' and chose custom installation then select the Base Application Development tools.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Dec 10 08:01:24 2019 UTC