php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58183 File Descriptor leak
Submitted: 2008-04-29 08:34 UTC Modified: 2008-04-30 06:52 UTC
From: vitaly4all at showbiz dot com dot ua Assigned:
Status: Duplicate Package: APC (PECL)
PHP Version: 4.4.7 OS: Linux 2.6.18-028
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vitaly4all at showbiz dot com dot ua
New email:
PHP Version: OS:

 

 [2008-04-29 08:34 UTC] vitaly4all at showbiz dot com dot ua
Description:
------------
File Descriptor leak

apache 2.0.63 error.log  - (24)Too many open files: unable to open...

lsof -Fn -u httpd | grep ".php$" | sort | uniq -c | sort -r | more
7385 ./../functions.php
1653 ./../Subs.php
1653 ./../Security.php
1653 ./../QueryString.php
1653 ./../Load.php
1653 ./../Errors.php
1653 ./../Settings.php
919  ./../Display.php
834  ./../last_advertisment.php



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-04-30 06:52 UTC] gopalv82 at yahoo dot com
http://pecl.php.net/bugs/bug.php?id=13542

Has already been fixed in CVS (branch APC_3_0) 

But there's an issue with php 5.3 which needs to be fixed before the next APC release can happen.

Wait for it! (and thanks for reporting the bug)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Dec 05 06:01:23 2020 UTC