php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58137 pecl install paradox fails
Submitted: 2008-04-03 17:55 UTC Modified: 2016-07-01 20:22 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: micahclarke at yahoo dot com Assigned:
Status: Suspended Package: Paradox (PECL)
PHP Version: 5.1.6 OS: Fedora 5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: micahclarke at yahoo dot com
New email:
PHP Version: OS:

 

 [2008-04-03 17:55 UTC] micahclarke at yahoo dot com
Description:
------------
Standard Fedora 5 install with everything up to date.

php config line: './configure' '--build=i686-redhat-linux-
gnu' '--host=i686-redhat-linux-gnu' '--target=i386-redhat-
linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-
prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--
sysconfdir=/etc' '--datadir=/usr/share' '--
includedir=/usr/include' '--libdir=/usr/lib' '--
libexecdir=/usr/libexec' '--localstatedir=/var' '--
sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--
infodir=/usr/share/info' '--cache-file=../config.cache' '--
with-libdir=lib' '--with-config-file-path=/etc' '--with-
config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-
pic' '--disable-rpath' '--without-pear' '--with-bz2' '--
with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-
dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--
without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' 
'--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--
with-pspell' '--with-expat-dir=/usr' '--with-pcre-
regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-
exif' '--enable-ftp' '--enable-magic-quotes' '--enable-
sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-
sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--
enable-yp' '--enable-wddx' '--with-kerberos' '--enable-ucd-
snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-
limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' 
'--enable-dio' '--with-mime-magic=/etc/httpd/conf/magic' '--
without-sqlite' '--with-libxml-dir=/usr' '--with-xml' '--
with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' 
'--without-odbc' '--disable-dom' '--disable-dba' '--without-
unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-
xmlwriter'

Attempted fix as per http://pecl.php.net/bugs/bug.php?
id=9488 but got exactly the same result

Reproduce code:
---------------
pecl install paradox

Expected result:
----------------
pecl to install paradox

Actual result:
--------------
[root@ds600 ~]# pecl install paradox
downloading paradox-1.4.3.tgz ...
Starting to download paradox-1.4.3.tgz (20,662 bytes)
........done: 20,662 bytes
4 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20050922
Zend Extension Api No:   220051025
building in /var/tmp/pear-build-root/paradox-1.4.3
running: /tmp/pear/download/paradox-1.4.3/configure
checking for egrep... grep -E
...'CHECKING' LINES...
checking for re2c... no
configure: WARNING: You will need re2c 0.9.11 or later if 
you want to regenerate PHP parsers.
...'CHECKING' LINES...
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/sh /var/tmp/pear-build-root/paradox-1.4.3/libtool 
...ETC...
mkdir .libs
gcc ...ETC...
/tmp/pear/download/paradox-1.4.3/paradox.c:93:45: error: 
macro "ZEND_ME_MAPPING" passed 4 arguments, but takes just 3
/tmp/pear/download/paradox-1.4.3/paradox.c:94:45: error: 
macro "ZEND_ME_MAPPING" passed 4 arguments, but takes just 3
/tmp/pear/download/paradox-1.4.3/paradox.c:93: error: 
'ZEND_ME_MAPPING' undeclared here (not in a function)
/tmp/pear/download/paradox-1.4.3/paradox.c:94: error: 
expected '}' before 'ZEND_ME_MAPPING'
/tmp/pear/download/paradox-1.4.3/paradox.c:95:49: error: 
macro "ZEND_ME_MAPPING" passed 4 arguments, but takes just 3
...MORE OF THE ABOVE LINE...
make: *** [paradox.lo] Error 1
ERROR: `make' failed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-04-04 04:19 UTC] micahclarke at yahoo dot cm
The reason the fix specified in bug 9488 didn't work is that 
the downloaded paradox.c is not the one with the problem.  As 
is obvious from the error message, I need to run the fix from 
bug 9488 over paradox.c in /tmp  However, as this is created 
on the fly I can't get at it.  Any suggestions?
 [2008-04-04 04:46 UTC] micahclarke at yahoo dot cm
Tried http://uk2.php.net/manual/en/install.pecl.phpize.php and 
the fix from bug 9488 actually added a parameter instead of 
removing it.

Did it manually.  Now it works.  Less than impressed with PECL 
from a functionality and documentation perspective.  Add a 
localinstall option and a man page.
 [2016-07-01 20:22 UTC] cmb@php.net
-Status: Open +Status: Suspended
 [2016-07-01 20:22 UTC] cmb@php.net
Apparently, the Paradox extension is not maintained anymore, so
I'm suspending this ticket until development continues.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Nov 25 03:01:23 2020 UTC