php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58077 regression test bug13090 crashes
Submitted: 2008-03-03 11:55 UTC Modified: 2008-04-01 09:31 UTC
From: mfp@php.net Assigned:
Status: Not a bug Package: SCA_SDO (PECL)
PHP Version: 5.2.1 OS: WinXP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mfp@php.net
New email:
PHP Version: OS:

 

 [2008-03-03 11:55 UTC] mfp@php.net
Description:
------------
I see that the bug13090 phpt regression test is supposed to watch for some error to do with namespaces, but it is failing with a more serious error altogether:

<b>Fatal error</b>:  Uncaught exception 'SDO_UnsupportedOperationException' with message 'main(): cannot cast integer to SDO_DataObject for 'creationType'' in C:\tests\SCA\phpt\bug13090.php:54

The line in question is 
$upl->creationType = 1234;

I am using FULMAR. 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-04-01 09:31 UTC] cem@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PECL.

You're describing the symptoms of bug 13090, which is not yet fixed.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 11:01:34 2019 UTC