php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58073 PDO_MYSQL crashes on Connect
Submitted: 2008-02-29 12:04 UTC Modified: 2008-03-02 20:08 UTC
From: akvochick at ds-creative dot com Assigned:
Status: Not a bug Package: PDO_MYSQL (PECL)
PHP Version: 5.2.1 OS: Mac OS 10.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: akvochick at ds-creative dot com
New email:
PHP Version: OS:

 

 [2008-02-29 12:04 UTC] akvochick at ds-creative dot com
Description:
------------
PDO_MYSQL (installed from pecl) crashes when I try to get a 
connection





Reproduce code:
---------------
Here is the code that causes the crash:

<?php
$databaseHandler = new PDO('mysql:host=127.0.0.1;dbname=locator', 'user', 'password');
?>

Expected result:
----------------
A database connection.

Actual result:
--------------
A crash.

Here is the crash report:

Host Name:      Backyard
Date/Time:      2008-02-29 11:43:21.357 -0500
OS Version:     10.4.10 (Build 8R218)
Report Version: 4

Command: php-cgi
Path:    /usr/local/php5/bin/php-cgi
Parent:  httpd [22293]

Version: ??? (???)

PID:    29729
Thread: 0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0x0ae25ebc

Thread 0 Crashed:
0   pdo_mysql.so 	0x024052cc add_compiled_collation + 40
1   pdo_mysql.so 	0x02405a64 init_available_charsets + 84
2   pdo_mysql.so 	0x02405870 get_charset_by_csname + 48
3   pdo_mysql.so 	0x024022ec mysql_init_character_set + 
132
4   pdo_mysql.so 	0x02402c3c mysql_real_connect + 2108
5   pdo_mysql.so 	0x023f966c pdo_mysql_handle_factory + 
2764 (mysql_driver.c:531)
6   php-cgi      	0x000d364c zim_PDO_dbh_constructor + 
2332 (pdo_dbh.c:372)
7   php-cgi      	0x002dfc2c 
zend_do_fcall_common_helper_SPEC + 2156 (zend_vm_execute.h:
200)
8   php-cgi      	0x002dcc58 execute + 392 
(zend_vm_execute.h:92)
9   php-cgi      	0x002bc6ec zend_execute_scripts + 364 
(zend.c:1135)
10  php-cgi      	0x00274a3c php_execute_script + 604 
(main.c:1982)
11  php-cgi      	0x00366068 main + 6376 (cgi_main.c:1784)
12  php-cgi      	0x00002544 _start + 340 (crt.c:272)
13  php-cgi      	0x000023ec start + 60

Thread 0 crashed with PPC Thread State 64:
  srr0: 0x00000000024052cc srr1: 0x000000000000d030                        
vrsave: 0x0000000000000000
    cr: 0x4404244c          xer: 0x0000000000000004   lr: 
0x000000000240e3d8  ctr: 0x0000000000000000
    r0: 0x0000000008a7b990   r1: 0x00000000bfffa880   r2: 
0x00000000024052ac   r3: 0x000000000230c548
    r4: 0x0000000000000021   r5: 0x00000000023aa52c   r6: 
0x00000000025052ac   r7: 0x000000000229ee64
    r8: 0x000000000240e3d8   r9: 0x0000000000000021  r10: 
0x00000000024fe0d4  r11: 0x00000000024fe0d4
   r12: 0x00000000024fe0d4  r13: 0x0000000000000000  r14: 
0x0000000000000000  r15: 0x0000000000000034
   r16: 0x00000000bfffb6d0  r17: 0x0000000000030000  r18: 
0x00000000018d9240  r19: 0x0000000000000cea
   r20: 0x0000000000000000  r21: 0x0000000000000000  r22: 
0x0000000002808582  r23: 0x00000000018ce7f8
   r24: 0x000000000261fc20  r25: 0x0000000002505a18  r26: 
0x0000000000000000  r27: 0x0000000000000000
   r28: 0x0000000002808200  r29: 0x000000000230c5ac  r30: 
0x00000000bfffa8b0  r31: 0x000000000240e0d4

Binary Images Description:
    0x1000 -   0x434fff php-cgi 	/usr/local/php5/bin/php-
cgi
  0xf9d000 -   0xfbbfff libjpeg.62.dylib 	/usr/local/php5/
lib/libjpeg.62.dylib
  0xfc3000 -   0xfcbfff mysql.so 	/usr/local/php5/lib/php/
extensions/no-debug-non-zts-20060613/mysql.so
 0x1808000 -  0x1840fff libt1.5.dylib 	/usr/local/php5/lib/
libt1.5.dylib
 0x1a05000 -  0x1a23fff libpng.3.dylib 	/usr/local/php5/lib/
libpng.3.dylib
 0x1a82000 -  0x1ab5fff libcurl.4.dylib 	/usr/local/php5/
lib/libcurl.4.dylib
 0x1c98000 -  0x1daafff libxml2.2.dylib 	/usr/local/php5/
lib/libxml2.2.dylib
 0x1fe4000 -  0x2046fff libnetsnmp.5.dylib 	/usr/lib/
libnetsnmp.5.dylib
 0x2073000 -  0x2085fff mysqli.so 	/usr/local/php5/lib/php/
extensions/no-debug-non-zts-20060613/mysqli.so
 0x2205000 -  0x229cfff libmysqlclient.15.dylib 
	/usr/local/mysql-5.0.45-osx10.4-powerpc/lib/
libmysqlclient.15.dylib
 0x23f7000 -  0x2427fff pdo_mysql.so 	/usr/local/php5/lib/
php/extensions/no-debug-non-zts-20060613/pdo_mysql.so
0x8fe00000 - 0x8fe52fff dyld 46.12	/usr/lib/dyld
0x90000000 - 0x901bcfff libSystem.B.dylib 	/usr/lib/
libSystem.B.dylib
0x90214000 - 0x90219fff libmathCommon.A.dylib 	/usr/lib/
system/libmathCommon.A.dylib
0x91110000 - 0x9111efff libz.1.dylib 	/usr/lib/libz.
1.dylib
0x91432000 - 0x9143dfff libgcc_s.1.dylib 	/usr/lib/
libgcc_s.1.dylib
0x91a17000 - 0x91adefff libcrypto.0.9.7.dylib 	/usr/lib/
libcrypto.0.9.7.dylib
0x92a00000 - 0x92aeefff libiconv.2.dylib 	/usr/lib/
libiconv.2.dylib
0x94eac000 - 0x94ed9fff com.apple.LDAPFramework 1.4.1 
(69.0.1)	/System/Library/Frameworks/LDAP.framework/
Versions/A/LDAP
0x94ee0000 - 0x94ef0fff libsasl2.2.dylib 	/usr/lib/
libsasl2.2.dylib
0x94ef4000 - 0x94f23fff libssl.0.9.7.dylib 	/usr/lib/libssl.
0.9.7.dylib
0x94f33000 - 0x94f50fff libresolv.9.dylib 	/usr/lib/
libresolv.9.dylib
0x9904b000 - 0x99058fff libbz2.1.0.dylib 	/usr/lib/
libbz2.1.0.dylib
0x9ca5d000 - 0x9ca6dfff libwrap.7.dylib 	/usr/lib/
libwrap.7.dylib

PHP Info:

Configure Command =>  './configure'  '--prefix=/usr/local/
php5' '--with-config-file-scan-dir=/usr/local/php5/php.d' 
'--enable-force-cgi-redirect' '--enable-cgi' '--enable-
fastcgi' '--with-iconv' '--with-iconv-dir=/usr' '--with-
openssl=/usr' '--with-mysql=shared,/usr/local/mysql' '--
with-mysqli=shared,/usr/local/mysql/bin/mysql_config' '--
enable-sqlite-utf8' '--enable-cgi' '--with-gd' '--with-
zlib=/usr' '--with-zlib-dir=/usr' '--with-png-dir=/usr/
local/php5' '--with-t1lib=/usr/local/php5' '--with-jpeg-
dir=/usr/local/php5' '--with-curl=/usr/local/php5' '--with-
gettext=shared,/usr/local/php5' '--with-libxml-dir=shared,/
usr/local/php5' '--with-ming=shared,/usr/local/php5' '--
enable-exif' '--enable-wddx' '--enable-soap' '--with-
xsl=shared,/usr/local/php5' '--enable-gd-native-ttf' '--
with-pear' '--with-openssl=/usr' '--with-ldap' '--with-
xmlrpc' '--with-snmp=/usr' '--enable-ftp' '--enable-sockets' 
'--enable-calendar' '--enable-bcmath' '--with-bz2=/usr' '--
enable-zip'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-03-02 20:08 UTC] akvochick at ds-creative dot com
I have two MySQL libraries installed, and I had compiled against the wrong one. Of course, I had to download the source and to point it at the right one since pecl would seem to make it impossible.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Nov 12 21:01:36 2019 UTC