php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58063 Apache crash on graceful start with imagick enabled
Submitted: 2008-02-26 04:12 UTC Modified: 2008-03-08 20:00 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: alain dot russell at blackpepper dot co dot nz Assigned:
Status: Wont fix Package: imagick (PECL)
PHP Version: 5.2.5 OS: Mac OS X Server (10.4.11)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alain dot russell at blackpepper dot co dot nz
New email:
PHP Version: OS:

 

 [2008-02-26 04:12 UTC] alain dot russell at blackpepper dot co dot nz
Description:
------------
With imagick enabled trying to start apache with 

/usr/local/apache2/bin/apachectl -k graceful causes Apache 
to crash with error messages:

httpd: unable to initialize module loader `No such file or 
directory'.
Warning: recursive semaphore lock detected!
Warning: recursive semaphore lock detected!

Disabling imagick.so in php.ini makes the crash stop

Versions:
PHP 5.2.5
imagick 2.1.1RC1 (Since 2.0 crash has occured)
ImageMagick 6.3.8 02/05/08 Q16





Reproduce code:
---------------
n/a

Expected result:
----------------
No Crash

Actual result:
--------------
httpd: unable to initialize module loader `No such file or 
directory'.
Warning: recursive semaphore lock detected!
Warning: recursive semaphore lock detected!





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-02-26 04:14 UTC] alain dot russell at blackpepper dot co dot nz
PHP Version is actually 5.2.5
 [2008-02-26 11:03 UTC] scottmac@php.net
Are you using 64-bit apache?
Is it the standard Apple build or have you built your own Apache / php?
 [2008-02-26 16:06 UTC] alain dot russell at blackpepper dot co dot nz
No - 32 Bit.
Apache + PHP are our own builds ..

./configure \
--with-mpm=prefork \
--enable-so \
--enable-mods-shared=all \
--enable-shared \
--disable-static \
--disable-unique-id \
--disable-ipv6 \
--enable-logio \
--enable-deflate \
--enable-rewrite \
--enable-ssl \
--with-ssl=/opt/local \
--with-z=/opt/local

./configure \
--prefix=/usr/local/php5 \
--enable-sockets \
--enable-mbstring=all \
--enable-mbregex \
--enable-ftp \
--enable-soap \
--enable-zip \
--enable-calendar \
--enable-exif \
--disable-cgi \
--with-libxml-dir=/opt/local \
--with-gd \
--with-jpeg-dir=/opt/local \
--with-png-dir=/opt/local \
--with-freetype-dir=/opt/local \
--with-mysql=/usr/local/mysql \
--with-mysqli=/usr/local/mysql/bin/mysql_config \
--with-apxs2=/usr/local/apache2/bin/apxs \
--with-pspell=/opt/local \
--with-tidy=/opt/local \
--with-openssl=/opt/local \
--with-zlib=/opt/local \
--with-curl=/opt/local \
--with-mcrypt=/opt/local \
--with-mhash=/opt/local \
--with-imap=/usr/local/imap-2006e \
--with-imap-ssl=/usr/local/imap-2006e \
--disable-debug

PHP Also has APC, GeoIP and PDFLib extensions added.
 [2008-03-08 03:56 UTC] alain dot russell at blackpepper dot co dot nz
Hi, Anything else I can help supply to find the problem ?
 [2008-03-08 15:10 UTC] mkoppanen@php.net
The failure described happens in ImageMagick magick/module.c when ImageMagick initializes modules.

Do the ImageMagick command line tools work in your installation?
 [2008-03-08 20:00 UTC] alain dot russell at blackpepper dot co dot nz
Yes - Command line works fine.

xxxx:~ admin$ convert -v
Version: ImageMagick 6.3.8 02/05/08 Q16 
http://www.imagemagick.org
Copyright: Copyright (C) 1999-2008 ImageMagick Studio LLC
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Dec 17 02:01:26 2018 UTC