php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58036 not all packages contain static libsasl.a
Submitted: 2008-02-10 07:58 UTC Modified: 2008-02-16 16:40 UTC
From: yselkowitz at users dot sourceforge dot net Assigned: jon (profile)
Status: Closed Package: sasl (PECL)
PHP Version: 5.2.1 OS: Cygwin
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: yselkowitz at users dot sourceforge dot net
New email:
PHP Version: OS:

 

 [2008-02-10 07:58 UTC] yselkowitz at users dot sourceforge dot net
Description:
------------
Some distros don't include a static libsasl.a, since there are anyway dynamic modules (in $libdir/sasl2).  In such a case, sasl-0.1.0 thinks libsasl is not present at all and bails out.  Patch below.

Reproduce code:
---------------
--- origsrc/sasl-0.1.0/config.m4    2004-01-23 02:34:28.000000000 -0600
+++ src/sasl-0.1.0/config.m4    2008-01-31 20:52:24.875000000 -0600
@@ -31,7 +31,7 @@
 
   AC_MSG_CHECKING(for SASL library in $SASL_DIR/lib)
   for i in $SEARCH_LIBS; do
-    if test -r $SASL_DIR/lib/lib$i.a; then
+    if test -r $SASL_DIR/lib/lib$i.a -o -r $SASL_DIR/lib/lib$i.$SHLIB_SUFFIX_NAME; then
       SASL_LIB=$i
       AC_MSG_RESULT(found -l$i)
     fi



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-02-16 16:40 UTC] jon@php.net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 15:03:41 2021 UTC