php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #57997 Use built-in glibc's functions when available
Submitted: 2008-01-08 19:36 UTC Modified: 2008-01-09 03:13 UTC
From: atomo64 at gmail dot com Assigned:
Status: Wont fix Package: timezonedb (PECL)
PHP Version: 5.2.1 OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: atomo64 at gmail dot com
New email:
PHP Version: OS:

 

 [2008-01-08 19:36 UTC] atomo64 at gmail dot com
Description:
------------
glibc provides functions to retrieve the time zone data which would be nice for php-timezonedb to use.
This would be very helpful to remove the need of an extra update on every new version of the Olson database.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-01-09 03:13 UTC] derick@php.net
THe problem is that glibc are different all across the board, and that the timezone database is not even always (fully) available. In order to promote portability between Operating Systems and just systems in general, relying on the glibc installed database is not a good idea. Another problem is that it might be installed in other locations for example, and that is required as glibc's timezone functions (http://theory.uwinnipeg.ca/gnu/glibc/libc_304.html) are totally not adequate for PHP.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Mar 30 12:01:25 2020 UTC