php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57993 nextRowset() gives SQLSTATE[HYC00]: Optional feature not implemented'
Submitted: 2008-01-07 08:23 UTC Modified: 2008-07-03 07:29 UTC
From: richard dot blockley at googlemail dot com Assigned:
Status: Not a bug Package: PDO_MYSQL (PECL)
PHP Version: Irrelevant OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
22 - 7 = ?
Subscribe to this entry?

 
 [2008-01-07 08:23 UTC] richard dot blockley at googlemail dot com
Description:
------------
The obviously much needed feature, PDOStatement::nextRowset() is seemingly not implemented.

This is fundamental to using stored procedures, to get at the multiple resultsets that they can return.

Lack of this feature is making PDO for mysql less mature than mysqli.

Reproduce code:
---------------
#38842
#39759
#12794


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-03 07:29 UTC] johannes at schlueters dot de
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PECL.

We are aware of the other reports and will fix that with the upcoming merge of pdo_mysqlnd into CVS.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jan 24 14:03:33 2022 UTC