php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57983 Unable to compile
Submitted: 2007-12-30 05:26 UTC Modified: 2007-12-30 18:39 UTC
From: dg at artegic dot de Assigned:
Status: Duplicate Package: APC (PECL)
PHP Version: 5.2.1 OS: solaris 10 x86
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: dg at artegic dot de
New email:
PHP Version: OS:

 

 [2007-12-30 05:26 UTC] dg at artegic dot de
Description:
------------
/APC-3.0.16/php_apc.c: In function ?zm_activate_apc?:
/APC-3.0.16/php_apc.c:303: error: too few arguments to 
function ?apc_set_signals?






Reproduce code:
---------------
Using gcc 4.0.2, PHP 5.2.5, Apache 2.2.6

CC=gcc CFLAGS="-w -O3 -threads -mtune=opteron" \
./configure \
--enable-apc \
--with-apxs=/apache/bin/apxs \
--with-php-config=/php/bin/php-config

I tried it with a lot of different configure/compiler settings  without success. No errors during the configure-process.

Expected result:
----------------
APC should compile under Solaris 10 with gcc 4.

Actual result:
--------------
Compilation abort with syntactical error.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-30 18:39 UTC] shire@php.net
This is a duplicate of bug #12777.  This has been fixed in CVS, you can checkout a copy there that should build correctly for your system.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 06:03:37 2021 UTC