php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57949 PDO_MYSQL installation
Submitted: 2007-12-03 21:38 UTC Modified: 2008-05-13 09:08 UTC
From: usa dot p dot kumar at gmail dot com Assigned:
Status: Not a bug Package: PDO_MYSQL (PECL)
PHP Version: 5_2 CVS-2007-12-03 OS: rhel 4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: usa dot p dot kumar at gmail dot com
New email:
PHP Version: OS:

 

 [2007-12-03 21:38 UTC] usa dot p dot kumar at gmail dot com
Description:
------------
pecl install -f PDO_MYSQL-1.0.2
downloading PDO_MYSQL-1.0.2.tgz ...
Starting to download PDO_MYSQL-1.0.2.tgz (14,778 bytes)
.....done: 14,778 bytes
downloading PDO-1.0.3.tgz ...
Starting to download PDO-1.0.3.tgz (52,613 bytes)
...done: 52,613 bytes
12 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
building in /var/tmp/pear-build-root/PDO-1.0.3
running: /tmp/pear/cache/PDO-1.0.3/configure
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.
ERROR: `/tmp/pear/cache/PDO-1.0.3/configure' failed
7 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
building in /var/tmp/pear-build-root/PDO_MYSQL-1.0.2
running: /tmp/pear/cache/PDO_MYSQL-1.0.2/configure
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.
ERROR: `/tmp/pear/cache/PDO_MYSQL-1.0.2/configure' failed

Reproduce code:
---------------
Starting to download PDO_MYSQL-1.0.2.tgz (14,778 bytes)
.....done: 14,778 bytes
downloading PDO-1.0.3.tgz ...
Starting to download PDO-1.0.3.tgz (52,613 bytes)
...done: 52,613 bytes
12 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
building in /var/tmp/pear-build-root/PDO-1.0.3
running: /tmp/pear/cache/PDO-1.0.3/configure
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.


Expected result:
----------------
Sucess

Actual result:
--------------
ERROR: `/tmp/pear/cache/PDO_MYSQL-1.0.2/configure' failed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-12-04 12:23 UTC] mikael at synd dot info
Moved misfiled bug
 [2008-05-13 09:08 UTC] johannes at schlueters dot de
This is not related to PDO_mysql, your systems seems to be missing some C development tools (C compiler or stdlib headers or something like that) please check the "install" seciton of the PHP documentation to get a list of required tools.
 [2009-07-13 11:55 UTC] ladadadada at hotmail dot com
The problem is most likely that your system (Probably RedHat or RedHat based) has /tmp mounted as noexec.  It also has /var/tmp symlinked to /tmp.

The configure script tries to build a simple compiled C program in /tmp regardless of the PECL config and then can't execute it due to the noexec option.  It chooses this directory during the phpize step and the value comes from the config.guess file.

The easiest way to make it work is either to symlink the appropriate directory somewhere else or remount /tmp.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Nov 16 23:01:41 2019 UTC