php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57935 maxdb_stmt: method close_long_result missing
Submitted: 2007-11-29 04:18 UTC Modified: 2017-04-01 20:48 UTC
From: mail at daniel-berlin dot de Assigned:
Status: Wont fix Package: maxdb (PECL)
PHP Version: 5.2.1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mail at daniel-berlin dot de
New email:
PHP Version: OS:

 

 [2007-11-29 04:18 UTC] mail at daniel-berlin dot de
Description:
------------
The close_long_data method of the maxdb_stmt
object is missing.

Reproduce code:
---------------
$q = $maxdb->stmt_init();
$q->prepare("...");
$q->bind_param("...", array(...));
$q->execute()
$q->send_long_data(2, "...");
$q->close_long_data(2);

-----------------------
Fix:

--- maxdb-7.6.00.38/php_maxdb.c 2007-04-20 13:11:08.000000000 +0200
+++ maxdb/php_maxdb.c   2007-11-29 10:03:01.000000000 +0100
@@ -417,6 +417,7 @@
  PHP_FALIAS(result_metadata, maxdb_stmt_result_metadata,NULL)
  PHP_FALIAS(num_rows, maxdb_stmt_num_rows,NULL)
  PHP_FALIAS(send_long_data,maxdb_stmt_send_long_data,NULL)
+ PHP_FALIAS(close_long_data,maxdb_stmt_close_long_data,NULL)
  PHP_FALIAS(stmt,maxdb_prepare,NULL)
  PHP_FALIAS(free_result,maxdb_stmt_free_result,NULL)
  PHP_FALIAS(reset,maxdb_stmt_reset,NULL)


Actual result:
--------------
PHP Fatal error:  Call to undefined method maxdb_stmt::close_long_data() in /srv/www/htdocs/...


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-29 08:04 UTC] mail at daniel-berlin dot de
...
 [2017-04-01 20:48 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 20:48 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2007, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Oct 18 22:01:26 2018 UTC