php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57929 Error while compiling
Submitted: 2007-11-24 15:55 UTC Modified: 2017-04-01 21:14 UTC
From: perrick at onpk dot net Assigned:
Status: Wont fix Package: Parse_Tree (PECL)
PHP Version: 5.2.1 OS: Mac OS X 10.4 Tiger
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: perrick at onpk dot net
New email:
PHP Version: OS:

 

 [2007-11-24 15:55 UTC] perrick at onpk dot net
Description:
------------
I downloaded the latest version 0.1.4 on my Mac OS X laptop. Running 'sudo /usr/local/php5.2.1/bin/phpize' went well but then I get an error while compiling.

Reproduce code:
---------------
- download latest version
- command : "sudo /usr/local/php5.2.1/bin/phpize"
- command : "./configure"
- command : "make"



Expected result:
----------------
Something like "everything is fine, please proceed"...

Actual result:
--------------
/bin/sh /Users/perrick/Desktop/parse_tree-0.1.4/parse_tree-0.1.4/libtool --mode=link gcc -DPHP_ATOM_INC -I/Users/perrick/Desktop/parse_tree-0.1.4/parse_tree-0.1.4/include -I/Users/perrick/Desktop/parse_tree-0.1.4/parse_tree-0.1.4/main -I/Users/perrick/Desktop/parse_tree-0.1.4/parse_tree-0.1.4 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend  -DHAVE_CONFIG_H  -g -O2   -o parse_tree.la -export-dynamic -avoid-version -prefer-pic -module -rpath /Users/perrick/Desktop/parse_tree-0.1.4/parse_tree-0.1.4/modules  parse_tree.lo php_lexer.lo php_parser.lo 
gcc ${wl}-flat_namespace ${wl}-undefined ${wl}suppress -o .libs/parse_tree.so -bundle  .libs/parse_tree.o .libs/php_lexer.o .libs/php_parser.o 
/usr/bin/ld: multiple definitions of symbol _yytext
.libs/php_lexer.o definition of _yytext in section (__DATA,__common)
.libs/php_parser.o definition of _yytext in section (__DATA,__data)
collect2: ld returned 1 exit status
make: *** [parse_tree.la] Error 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 21:14 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:14 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2007, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 19 07:01:23 2020 UTC