php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5788 Segmentation fault with posix_getpwnam & posix_getpwuid
Submitted: 2000-07-26 03:37 UTC Modified: 2000-08-15 10:56 UTC
From: bayard at uncnet dot com Assigned:
Status: Closed Package: Other
PHP Version: 4.0.1pl2 OS: Redhat Linux 6.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: bayard at uncnet dot com
New email:
PHP Version: OS:

 

 [2000-07-26 03:37 UTC] bayard at uncnet dot com
A php script which call posix_getpwnam/posix_getpwuid will cause segmentation fault if included too deep in include stack.

If the parameter passed to these 2 functions not a valid system user name/id, then error will not occur. SEG FAULT appears only called with valid user name/id.

Other posix related functions don't have this problem.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-26 14:43 UTC] stas@php.net
Couldn't reproduce it. Please try latest CVS and if it still crashes, please provide reproducing script and backtrace, if possible.
 [2000-08-15 10:56 UTC] waldschrott@php.net
Closed due to missing user feedback.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Thu Jan 26 22:05:54 2023 UTC