php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57821 can php5.2.3 support Java Integration?
Submitted: 2007-09-03 03:54 UTC Modified: 2007-09-03 12:20 UTC
From: yzb81 at 163 dot com Assigned:
Status: Not a bug Package: PECL bug system (PECL)
PHP Version: 5.2.1 OS: Windows XP SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: yzb81 at 163 dot com
New email:
PHP Version: OS:

 

 [2007-09-03 03:54 UTC] yzb81 at 163 dot com
Description:
------------
My php version is 5.2.3,apache version is 2.2.4,and my workstation is Windows XP SP2. Now I won't configure php to support Java Integration.

My jdk version is jdk1.5.0.

Reproduce code:
---------------
My php.ini configuration for Java is:

extension=php_java.dll
[Java]
java.class.path = "D:\php5\ext\php_java.jar; C:\Program Files\Java\jdk1.5.0\jre\lib;C:\Program Files\Java\jdk1.5.0;"
Java.home = "C:\Program Files\Java\jdk1.5.0\bin"
java.library = "C:\Program Files\Java\jdk1.5.0\jre\bin\server\jvm.dll" 
java.library.path = "D:\php5\ext"


My test sample is :

<?
// get instance of Java class java.lang.System in PHP
$system = new Java('java.lang.System');

// demonstrate property access
echo 'Java version=' . $system->getProperty('java.version') . '<br />';
echo 'Java vendor=' . $system->getProperty('java.vendor') . '<br />';
echo 'OS=' . $system->getProperty('os.name') . ' ' .
             $system->getProperty('os.version') . ' on ' .
             $system->getProperty('os.arch') . ' <br />';

// java.util.Date example
$formatter = new Java('java.text.SimpleDateFormat',
                      "EEEE, MMMM dd, yyyy 'at' h:mm:ss a zzzz");

echo $formatter->format(new Java('java.util.Date'));
?>

Expected result:
----------------
When I run the test sample,the apache httpd.exe occured an error and the script doesn't run correctly.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-09-03 12:20 UTC] greg at chiaraquartet dot net
this is not a bug, you need technical support.  please 
email php-general@lists.php.net for support questions
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Dec 04 04:03:34 2021 UTC