php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57817 make pharcmd use installed phar.so, not build one
Submitted: 2007-08-31 09:15 UTC Modified: 2007-11-22 13:43 UTC
From: Fedora at FamilleCollet dot com Assigned:
Status: Not a bug Package: phar (PECL)
PHP Version: 5.2.1 OS: Linux (Fedora)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Fedora at FamilleCollet dot com
New email:
PHP Version: OS:

 

 [2007-08-31 09:15 UTC] Fedora at FamilleCollet dot com
Description:
------------
Running 'make pharcmd' use phar.so previously installed and fail if not.

I think using the "just build" phar.so is better.

Attached patch allow this.

--- Makefile.frag.makepatch     2007-08-30 05:34:34.000000000 +0200
+++ Makefile.frag       2007-08-31 14:45:52.000000000 +0200
@@ -2,12 +2,14 @@
 $(srcdir)/phar_path_check.c: $(srcdir)/phar_path_check.re
        $(RE2C) -b -o $(srcdir)/phar_path_check.c $(srcdir)/phar_path_check.re)
 
-pharcmd: $(builddir)/phar.php $(builddir)/phar.phar
+pharcmd: $(all_targets) $(builddir)/phar.php $(builddir)/phar.phar
 
 $(builddir)/phar.php: $(srcdir)/build_precommand.php $(srcdir)/phar/*.inc $(srcdir)/phar/*.php
-       php $(srcdir)/build_precommand.php > $(builddir)/phar.php
+       php -n -q -d extension_dir=$(builddir)/modules -d extension=phar.so\
+               $(srcdir)/build_precommand.php > $(builddir)/phar.php
 
 $(builddir)/phar.phar: $(builddir)/phar.php $(srcdir)/phar/*.inc $(srcdir)/phar/*.php
-       php -d phar.readonly=0 $(srcdir)/phar.php pack -f $(builddir)/phar.phar -a pharcommand -c auto -x CVS -p
 0 -s $(srcdir)/phar/phar.php -h sha1 $(srcdir)/phar/
+       php -n -q -d extension_dir=$(builddir)/modules -d extension=phar.so -d phar.readonly=0 \
+               $(srcdir)/phar.php pack -f $(builddir)/phar.phar -a pharcommand -c auto -s $(srcdir)/phar/phar.p
hp -h sha1 $(srcdir)/phar/
        @chmod +x $(builddir)/phar.phar
 


Reproduce code:
---------------
-

Expected result:
----------------
-

Actual result:
--------------
-

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-11-22 13:26 UTC] greg at chiaraquartet dot net
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 [2007-11-22 13:43 UTC] greg at chiaraquartet dot net
this patch breaks "make" on unix, and can't work on Windows because all .dll are in $(builddir) and are named php_phar.dll

reverting
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Feb 24 21:01:24 2021 UTC