php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57815 Current CVS trunk (1.2.4?) doesn't compile for me
Submitted: 2007-08-30 17:44 UTC Modified: 2007-08-30 18:36 UTC
From: gena01 at gmail dot com Assigned:
Status: Not a bug Package: oci8 (PECL)
PHP Version: 5.1.6 OS: Mandriva Linux 2007.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gena01 at gmail dot com
New email:
PHP Version: OS:

 

 [2007-08-30 17:44 UTC] gena01 at gmail dot com
Description:
------------
I can compile oci8 1.2.3 just fine. I wanted to see if I can compile CVS version and it fails for me. It has something to do with "zstr" which is not defined anywhere on my system.

The messages that I am getting look like:
/home/zzz/oci8/pecl/oci8/oci8.c: In function ?php_oci_define_hash_dtor?:
/home/zzz/oci8/pecl/oci8/oci8.c:771: error: request for member ?v? in something not a structure or union
/home/zzz/oci8/pecl/oci8/oci8.c:772: error: request for member ?v? in something not a structure or union
/home/zzz/oci8/pecl/oci8/oci8.c:773: error: request for member ?v? in something not a structure or union
/home/xxx/oci8/pecl/oci8/oci8.c: In function ?php_oci_column_hash_dtor?:
/home/xxx/oci8/pecl/oci8/oci8.c:825: error: request for member ?v? in something not a structure or union
/home/zzz/oci8/pecl/oci8/oci8.c:826: error: request for member ?v? in something not a structure or union
/home/zzz/oci8/pecl/oci8/oci8.c: In function ?php_oci_error?:


Reproduce code:
---------------
it seems that zstr is being used, but not defined anywhere.

Expected result:
----------------
I expect oci8 to compile and work.

Actual result:
--------------
It breaks during compilation.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-08-30 18:36 UTC] tony at daylessday dot org
Current CVS HEAD is for PHP6 (HEAD), you need 5_2 branch if you're compiling it with PHP 5_2.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Dec 04 10:03:34 2021 UTC