|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #578 Apache 1.3.0 will not recognize php3 extension as a mime type
Submitted: 1998-07-24 15:37 UTC Modified: 1998-09-19 16:55 UTC
From: dylan at macrodesign dot com Assigned:
Status: Closed Package: Installation problem
PHP Version: 3.0.2a OS: Red Hat 5.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
40 - 35 = ?
Subscribe to this entry?

 [1998-07-24 15:37 UTC] dylan at macrodesign dot com
after installing and setting the server up with the script provided in 3.0.2a installation file 'INSTALL'
where i ran the folowing steps

cd apache _1.3.0
./configure --prefix=/www
cd ../php-3.0.2a
./configure --with-apache=../apache_1.3.0 --enable-track-vars
make install
cd ../apache_1.3.0
./configure --prefix=/www --activate-module=src/modules/php3/libphp3.a
make install
cd ../php-3.0.2a
cp php3.ini-dist /usr/local/lib/php3.ini

I then added a line to the following lines to the http.conf and srm.conf found in my

AddType application/x-httpd-php3 .php3

then in the apache1.3.0 directory I ran

/www/sbin/apachectl stop
/www/sbin/apachectl start

I then installed PTS from 
in my WWW root directory and the system would give me the .php3
that is correct

I need to have this operational by next week.

Or else they are going to make me develop "APS's" from microsoft.
Any help would be appreciated.

I dont see what is keeping the php3 type mime from coming through the apache server

If you want a look inside you can log on as me 
UID: csdylan

then get root at su

please feel free to criticize me I am only novice at this Apache module stuff and need a helping hand


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [1998-09-19 16:55 UTC] zeev
Did you get that fixed?
If not, I hope you at least changed your root password there, since *anyone* can see it here.

If you didn't get it work yet, what exactly are the symptoms?  Do you see the source of the PHP script instead
of its output?

Are you sure you updated the actual httpd.conf/srm.conf that Apache is using, and not some other files?

No user response for a while.
This very much looks as if you edited the wrong .conf file,
make sure that you're changing the .conf files that
Apache is actually reading.
 [2023-01-27 17:27 UTC] iiidjet at mail dot com
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 19 11:01:37 2024 UTC