php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57798 Configure failing on PHP version check
Submitted: 2007-08-26 19:33 UTC Modified: 2009-02-06 16:37 UTC
From: amiller at onlinebrands dot com Assigned:
Status: No Feedback Package: imagick (PECL)
PHP Version: 5.2.1 OS: Mac OS X 10.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: amiller at onlinebrands dot com
New email:
PHP Version: OS:

 

 [2007-08-26 19:33 UTC] amiller at onlinebrands dot com
Description:
------------
The configure script does not recognize that I have a new enough version of PHP installed and keeps telling me that I need a newer version than 5.1.3 when I actually have 5.2.3 installed. It's a pain. 

Reproduce code:
---------------
checking if PHP version is at least 5.1.3... configure: error: no. You need at least PHP version 5.1.3 to use Imagick. 

Expected result:
----------------
I would expect that the configure script would recognize that I have a version of PHP running that is newer than 5.1.3 when I am running 5.2.3. See below for example. 

Actual result:
--------------
prompt$ which php
/usr/bin/php


prompt$ php -v
PHP 5.2.3 (cli) (built: Jun 16 2007 21:05:51) 
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies


prompt$ ./configure
checking for egrep... grep -E
checking for a sed that does not truncate output... /usr/bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking whether gcc and cc understand -c and -o together... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... no
./configure: line 2789: PHP_SHLIB_SUFFIX_NAMES: command not found
checking build system type... i686-apple-darwin8.10.1
checking host system type... i686-apple-darwin8.10.1
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend
checking for PHP extension directory... /usr/lib/php/extensions/no-debug-non-zts-20020429
checking for PHP installed headers prefix... Usage: /usr/bin/php-config [--prefix|--includes|--ldflags|--libs|--extension-dir|--version]
checking for re2c... re2c
./configure: line 3010: PHP_PROG_AWK: command not found
checking whether to enable the imagick extension... yes, shared
checking whether to enable the imagick GraphicsMagick backend... no
checking Wand-config in default path... found in /usr/local/bin
checking for magick-wand.h header file... found in /usr/local/include/wand/magick-wand.h
checking if ImageMagick version is at least 6.2.4... found version 6.3.4
checking if PHP version is at least 5.1.3... configure: error: no. You need at least PHP version 5.1.3 to use Imagick. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-08-26 20:18 UTC] mkoppanen@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PECL.


I assume your error is related to this configuration error:

./configure: line 3010: PHP_PROG_AWK: command not found

Can you try to install awk (it is used to detect PHP version) and retry configuration?
 [2007-08-26 20:24 UTC] mkoppanen@php.net
Last post should've said "used in detecting" not "to detecting".

Can you also check what php-config --version returns ?
 [2009-02-06 16:37 UTC] mkoppanen@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 22 02:01:23 2019 UTC