php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57763 pdo_mysql emits gives api version errors in log
Submitted: 2007-07-31 06:45 UTC Modified: 2008-05-08 11:04 UTC
From: chrissavery at gmail dot com Assigned:
Status: Not a bug Package: PDO_MYSQL (PECL)
PHP Version: 5.2.1 OS: Linux Centos 2.6.15
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: chrissavery at gmail dot com
New email:
PHP Version: OS:

 

 [2007-07-31 06:45 UTC] chrissavery at gmail dot com
Description:
------------
First off - you don't have 5.2.3 in the list above for php version choices. Second, I see a link above that says if you'r e not sure it's a bug then see these support resources - but that link is dead, nothing there. So I'm reporting a bug because after looking all over here I can't find any information about how to get around this problem. I presume it's some version issue and not really a bug.

SO the problem:

On PHP 5.2.3 with current release of pdo_mysql (1.0.2).

After installing pdo_mysql using: pecl install pdo_mysql
it appeared as though things were going to work fine.

However everytime PHP starts (including whe run as CLI from cron) it emits an error message in to the log stating there is an API version mismatch and that these versions need to match. It seems as though this is a meaningless warning as an application I'm using which needs pdo_mysql appears to still function.


Reproduce code:
---------------
Here is detail of error message logged:

PHP Warning:  PHP Startup: pdo_mysql: Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=0
PHP    compiled with module API=20060613, debug=0, thread-safety=0
These options need to match
 in Unknown on line 0


Expected result:
----------------
Umm. No error message. Presumably this recent update 5.2.3 of php has also incremented the API version. I don't know much about that but I get hundreds of these error messages. I'd like to know how to fix this or if a new version that is compatible will be released sometime. If this is a meaningless  error message then perhaps the module should be compiled so as not to generate error messages then.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-05-08 11:04 UTC] johannes at schlueters dot de
You have to use the php development files from the correct version when compiling an extension
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 08:01:31 2019 UTC