php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57758 PDO_OCI and Cursor
Submitted: 2007-07-23 05:50 UTC Modified: 2012-06-26 23:28 UTC
From: aranna at free dot fr Assigned:
Status: Duplicate Package: *General Issues
PHP Version: Irrelevant OS: RedHat 4 Ent
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: aranna at free dot fr
New email:
PHP Version: OS:

 

 [2007-07-23 05:50 UTC] aranna at free dot fr
Description:
------------
Here the oracle storage procedure content:
==========================================

PROCEDURE REQ_TEST_PAK (res IN OUT REQ_9COLONNES_PKG.resultat)
AS

BEGIN

OPEN res FOR
SELECT *
FROM AGENCP;

END REQ_TEST_PAK;


Reproduce code:
---------------
Here the PHP code :
===================
...
  $stmt = $oracle->prepare("call FM.REQ_TEST_PAK(?)");
  $stmt->bindParam(1, $toto, PDO::PARAM_INPUT_OUTPUT, 4000);
...

Expected result:
----------------
Result of execution

Actual result:
--------------
Re: ORA-06553: PLS-306: wrong number or types of arguments 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-08 13:44 UTC] tfalgout at yahoo-inc dot com
Is there any update on this?  I'm also encountering the same issue.
 [2012-06-26 23:28 UTC] sixd@php.net
Closing as a dup of https://bugs.php.net/bug.php?id=60703 since it has more info 
and an (unreviewed) patch.
 [2012-06-26 23:28 UTC] sixd@php.net
-Status: Open +Status: Duplicate -Package: PDO_OCI +Package: *General Issues
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Jan 24 00:01:23 2021 UTC