php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57689 bug for disabling values
Submitted: 2007-06-02 20:04 UTC Modified: 2007-06-03 06:01 UTC
From: daryl at berjeuxlan dot org Assigned: pajoye (profile)
Status: Not a bug Package: htscanner (PECL)
PHP Version: 5.2.1 OS: Debian Etch
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: daryl at berjeuxlan dot org
New email:
PHP Version: OS:

 

 [2007-06-02 20:04 UTC] daryl at berjeuxlan dot org
Description:
------------
disabling values in a .htaccess file that are enabled from php.ini works fine, but enabling values that are desabled doesn't work !
The bug is the same with htscanner compiled for php4 or php5

Expected result:
----------------
"php_value register_globals 1" to make the value enabled

Actual result:
--------------
"php_value register_globals 0" works if register_globals is "On" in php.ini

"php_value register_globals 1" doesn't work if register_globals is "Off" in php.ini

"php_value register_globals 1" makes register_globals to "Off" if register_globals is "On" in php.ini

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-06-03 06:01 UTC] pierre dot php at gmail dot com
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PECL.

Duplicate of #10623 and #11088.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 01:05:44 2022 UTC