|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57674 Unable to load php_ssh2.dll
Submitted: 2007-05-16 11:06 UTC Modified: 2012-06-12 14:35 UTC
From: thiagomp at gmail dot com Assigned: langemeijer (profile)
Status: Closed Package: ssh2 (PECL)
PHP Version: 5.2.1 OS: windows 2003 sp1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: thiagomp at gmail dot com
New email:
PHP Version: OS:


 [2007-05-16 11:06 UTC] thiagomp at gmail dot com

First of all, the error occurs on php 5.2.2. When I came to report the bug, I did'nt find php 5.2.2 option at the php version field.

Lets to the bug.

I've installed php_ssh2.dll from php installer, but, when I go to ms-dos prompt and send a php -v command, I get the following error:

C:\Documents and Settings\thiago>php -v
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\Program Files\PHP\
ext\php_ssh2.dll' - The operating system cannot run %1.
 in Unknown on line 0
PHP 5.2.2 (cli) (built: May  2 2007 19:18:26)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies

Also, a window jump with the following message:

The ordinal 3874 could not be located in the dynamic link library LIBEAY32.dll

I've downloaded php_ssh2.dll module from CVS but the error remains the same.

I've moved LIBEAY32.dll to c:\windows and c:\windows\system32 but the error still happens.

Despite the fact that Apache was not used until now, on my machine I've installed Apache 2.2.4.

Thanks for your help


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2007-05-16 11:16 UTC] thiagomp at gmail dot com
For you information.

I've downgraded php version to 5.2.1 and get php_ssh2.dll functional.
 [2007-06-14 16:02 UTC] asdfpaul at yahoo dot com
I did try the downgrade but it did not work for me.

Maybe somebody care to explain this 'The operating system cannot run %1.' - error - would probably give us a hint too in finding an answer.

And helpful would be also to know where this might come from: "The ordinal 3874 could not be located in the dynamic link library

What I allready tried:
a) php 5.2.2 / each lib available on the pecl site
b) php 5.2.1 / each lib available on the pecl site
b) php 5.2.3 / each lib available on the pecl site

result: none was a successful combination

I have PATH pointing to both php main dir and php/ext dir

I have also tried moving all the dlls in the main dir in the system32 dir same issue

Now I'm getting a bit dispaired because I see it did work for others and I'm starting to wonder if I did something worng just like thiagomp.

I checked the dependencies of both php.exe and the php_ssh2.dll - both come out clear.
 [2007-08-23 20:53 UTC] roger at email dot com dot br
I've got the same situation as asdfpaul at yahoo dot com with the same error message.

I use php 5.2.3 with Apache 2.2.4 with SSL in WinXP SP2.

Also tried to downgrade to 5.2.2 and 5.2.1 with no success.
 [2007-12-04 13:38 UTC] roger at email dot com dot br
I already tried php 5.2.5 with no success. I'm using Windows XP SP2.
 [2008-10-02 03:52 UTC] agp77mix at mixmail dot com
I had the same problem. The solution was to copy the PHP bundled libeay32.dll file to the "bin" directory of Apache.

It seems that php_ssh2.dll needs a newer version of the DLL than the one included in Apache, and although you copy it to C:\WINDOWS or C:\WINDOWS\System32 it tries to load it from the Apache bin directory.
 [2012-06-12 14:35 UTC]
-Status: Open +Status: Closed -Assigned To: +Assigned To: langemeijer
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Sep 30 20:01:25 2023 UTC