php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57672 sqlite_escape_string dies on amd64
Submitted: 2007-05-15 15:56 UTC Modified: 2008-10-24 17:58 UTC
From: phpbugs at wheelhouse dot org Assigned: kalle (profile)
Status: Closed Package: SQLite (PECL)
PHP Version: 4.4.5 OS: Any amd64
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: phpbugs at wheelhouse dot org
New email:
PHP Version: OS:

 

 [2007-05-15 15:56 UTC] phpbugs at wheelhouse dot org
Description:
------------
This bug has apparently been fixed in CVS (and for PHP 5) for a long time, but there has been no new release in almost 3 years.

This bug was previously reported as 8581 but was marked closed due to being fixed in CVS.  Fixed in CVS is not useful to production sites, so this bug is still a serious problem.


Reproduce code:
---------------
--- sqlite.c-   Tue May 15 12:53:24 2007
+++ sqlite.c    Tue May 15 12:42:45 2007
@@ -1779,7 +1779,7 @@
 PHP_FUNCTION(sqlite_escape_string)
 {
        char *string = NULL;
-       long stringlen;
+       int stringlen;
        char *ret;
 
        if (FAILURE == zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "s", &string, &stringlen)) {




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-24 17:58 UTC] kalle@php.net
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/SQLite

This is/was fixed in the main php source, as pecl/sqlite is released in the php-src.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Oct 18 18:03:40 2021 UTC