php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #57631 way to obtain keys currently in memory?
Submitted: 2007-04-23 16:21 UTC Modified: 2007-04-23 20:09 UTC
From: stevebarg at gmail dot com Assigned:
Status: Not a bug Package: memcache (PECL)
PHP Version: 5.1.6 OS: linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: stevebarg at gmail dot com
New email:
PHP Version: OS:

 

 [2007-04-23 16:21 UTC] stevebarg at gmail dot com
Description:
------------
I would like to create an interface to allow a user to expire certain memcache items.  The problem is, I cannot find a way to get the keys for the memcache items currently in memory and storing the key values upon initial creation would become a data nightmare.

Is there something I am missing?  A way to grab all the memcache keys currently in memory and cycle through them?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-23 20:09 UTC] tony2001 at phpclub dot net
Well, you might probably want to ask memcached (i.e. the daemon) developers to add a way to do it, since an interface like PECL/memcache can't do it for you.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri May 24 05:01:32 2024 UTC