|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57630 pecl can't find apr includes
Submitted: 2007-04-23 12:33 UTC Modified: 2008-01-29 22:30 UTC
From: ziggurism at gmail dot com Assigned:
Status: Closed Package: svn (PECL)
PHP Version: 5.2.1 OS: Ubuntu Feisty Fawn
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
39 - 25 = ?
Subscribe to this entry?

 [2007-04-23 12:33 UTC] ziggurism at gmail dot com
I've just switched from gentoo to ubuntu, and unfortunately the pecl svn package seems to be unable to install on this system.

# pecl install channel://
downloading svn-0.2.tgz ...
Starting to download svn-0.2.tgz (16,843 bytes)
......done: 16,843 bytes
6 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
building in /var/tmp/pear-build-root/svn-0.2
running: /tmp/pear/cache/svn-0.2/configure
checking for specifying the location of apr for svn... yes, shared
checking for svn includes... configure: error: failed to find apr.h
ERROR: `/tmp/pear/cache/svn-0.2/configure' failed

I have the file:

# find / -name apr.h -print 2>/dev/null

The system reports that the file is part of the ubuntu libapr1-dev package:

# dpkg -S /usr/include/apr-1.0/apr.h
libapr1-dev: /usr/include/apr-1.0/apr.h

I also have installed these packages, which may be relevant:

$ dpkg --get-selections | grep subversion
subversion                                      install
$ dpkg --get-selections | grep svn
libsvn-dev                                      install
libsvn1                                         install
$ dpkg --get-selections | grep apr
libapr0                                         install
libapr1                                         install
libapr1-dev                                     install
libaprutil1                                     install
libaprutil1-dev                                 install

So it seems to me that I have all the dependencies (apr) installed, right?  Is this a bug in the configure script?



Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-25 00:15 UTC] alan at akbkhome dot com
can you try the cvs version 

cvs co pecl/svn 
cd svn
make instal

I think i fixed this recently.
 [2007-04-25 11:50 UTC] ziggurism at gmail dot com
Hi Alan-

Yes, it's working now!  Thank you thank you thank you!!!

Hey, I did phpize5 instead of phpize.  It showed up in tab-completion, and I thought since I'm running php5, I should prefer that version.  Don't know if that matters.

Anyway, thanks again!
 [2007-05-31 21:47 UTC] moeffju+php at moeffju dot net
An easier way is to checkout the source as described, then just run 'pecl install package2.xml' in the source dir.
 [2007-08-31 22:44 UTC] christoph at christophdorn dot com
I am trying to install this package on Mac OS X 10 using the CVS source and "pecl install package2.xml" as well as "phpize
./configure" and am getting same error:

checking for svn support... yes, shared
checking for specifying the location of apr for svn... yes, shared
checking for svn includes... configure: error: failed to find apr.h

I found apr.h in /Library/Apache2/include/apr.h and /usr/local/apr/include/apr-0/apr.h

Is there a way to manually specify where the header file is to be found?
 [2007-09-02 13:59 UTC] christoph at christophdorn dot com
It configures now when I specify the following:

./configure --with-svn-apr=/usr/local/apr/
 [2007-11-09 10:45 UTC] luser at hotmail dot com
I'm having a similar issue trying to install on OS X, using the MAMP distribution.  I have the apr source files in multiple places:


I have tried configure, specifying all of these paths for --with-svn-apr, but still get the 'failed to find apr.h' error...Not sure what to do to fix this...
 [2008-01-29 22:30 UTC] alan at akbkhome dot com
please open a new bug of OSX issues - and suggest fixes
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Aug 12 07:01:25 2020 UTC