php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57612 Building fails due to botched autoconf scripts
Submitted: 2007-04-06 13:22 UTC Modified: 2007-04-06 21:02 UTC
From: robe at amd dot co dot at Assigned:
Status: Not a bug Package: memcache (PECL)
PHP Version: 4.3.10 OS: Debian Sarge
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: robe at amd dot co dot at
New email:
PHP Version: OS:

 

 [2007-04-06 13:22 UTC] robe at amd dot co dot at
Description:
------------
Installation of memcache 2.1.2 fails because the $abs_scrdir variable which is referenced in config9.m4 in the php_session.h check points to the temporary building directory and not to the include directories referenced by `php-config --includes`.

Installing memcache 2.1.0 works fine.

Reproduce code:
---------------
pear install output: http://phpfi.com/224403
autogenerated configure script: http://amd.co.at/data/memcache-broken-configure.txt


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-04-06 15:21 UTC] tony2001 at phpclub dot net
Duplicate of bug #10541.
You're using a patched build, so you have to patch memcache accordingly.
 [2007-04-06 21:02 UTC] robe at amd dot co dot at
Tony, I seldom get angry at open source developers, 
recognizing the time and effort they put into software we 
can use freely, but when somebody tries to insult my 
intellect I get mad.

Please correct me if I'm wrong here, but isn't php-config 
supposed to help authors of "third party" addons to find the 
right include paths on "distribution-maintained" 
installations (which fix the "broken" (WRT parallel 
installations of php4 and php5) include-file layout which 
PHP created in the first place)? And wouldn't using php-
config solve all problems which might arise with this 
situation? Leaving all Debian and Ubuntu users out in the 
rain isn't a good move; Redhat apparently never cared too 
much about forward/backward compatibility (they made a clean 
switch from RHEL4 to 5 moving from PHP4 to 5 respectively).

I'd accept if you said that you don't have the time/
knowledge/nerve to implement such a solution (knowing what a 
PITA autoconf can be) but just filing this bug as bogus is 
preposterous.

Thank you for your time,
Michael
 [2007-05-11 09:40 UTC] d05h at uni-bremen dot de
Hi,

I've  found an easier solution without wating for anybody to fix something....

http://www.voidberg.org/blog/how_to_compile_and_install_the_php_4_memcached_extension.html

Jan
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Nov 27 13:03:14 2021 UTC