php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #57584 blocking php_value safe_mode
Submitted: 2007-03-20 16:45 UTC Modified: 2007-03-20 18:58 UTC
From: mkent at magoazul dot com Assigned: pajoye (profile)
Status: Closed Package: htscanner (PECL)
PHP Version: 5.2.1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mkent at magoazul dot com
New email:
PHP Version: OS:

 

 [2007-03-20 16:45 UTC] mkent at magoazul dot com
Description:
------------
Looks like a typo preventing php_value safe_mode on/off from making it to zend_alter_ini_entry

Reproduce code:
---------------
quick fix http://magoazul.com/tmp/htscanner-0.8.0-blocksafemode.patch

Expected result:
----------------
attempting to disable safe mode via .htaccess should fail

Actual result:
--------------
Warning: Adding option (Name: safe_mode Value: 0) (9, 1) failed! in Unknown on line 0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2007-03-20 18:58 UTC] pierre dot php at gmail dot com
This bug has been fixed in CVS.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

Thanks for the patch!

applied, will be in 0.8.1
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC